GraphWeaver Library

[image]

GraphWeaver For Visio ver.1.10
GraphWeaver Library
フィードバックの送信
GraphWeaver For Visio

名前空間

名前空間 | 説明
Sakura.GW.AbstractLayer | GraphWeaver 抽象レイヤー
Sakura.GW.AbstractLayer.Visio | GraphWeaver Visio抽象レイヤー
Sakura.GW.Lib | GraphWeaver コモンライブラリ

このトピックに対してコメントを送信 softinfo@sakura-system.com

Copyright 2009 （有）さくらシステム


Sakura.GW.AbstractLayer 名前空間

[image]

GraphWeaver For Visio ver.1.10
Sakura.GW.AbstractLayer 名前空間
フィードバックの送信
GraphWeaver 抽象レイヤー

クラス

クラス | 説明
GraphWeaver_AxisPack | 軸情報設定クラス
GraphWeaver_BarPack | 棒情報設定クラス
GraphWeaver_FontAttribute | フォント属性
GraphWeaver_PointPack | 点情報設定クラス
GraphWeaverData | GraphWeaver設定クラス
RGB | RGB色クラス

構造体

構造体 | 説明
GraphWeaver_AxisPack..::.Additional1 | 第1補助線属性
GraphWeaver_AxisPack..::.Additional2 | 第2補助線属性

列挙体

列挙体 | 説明
AxisArrowStyle | 軸矢印形式
AxisSpec | 軸種別
BarStyle | 棒形状
BarType | 棒表示方向
ColorIndex | 色インデックス
GraphType | グラフ種別
GraphWeaver_DataInputSpec | データ入力種別
GraphWeaver_DataType | 入力データファイルタイプ
GraphWeaver_TargetSeries | 対象系列種別
GraphWeaverData..::.CommandID | コマンドID
LengthUnit | 長さ単位種別
PointStyle | 点形状
Quadrant | 象限種別


AxisArrowStyle 列挙体

[image]

GraphWeaver For Visio ver.1.10
AxisArrowStyle 列挙体
参照 フィードバックの送信
軸矢印形式

名前空間 Sakura.GW.AbstractLayer
アセンブリ： Sakura.GW.AbstractLayer (Sakura.GW.AbstractLayer.dll 内)
バージョン: 1.1.0.0 (1.1.0.0)

構文

C#
public enum AxisArrowStyle
Visual Basic (宣言)
Public Enumeration AxisArrowStyle
Visual C++
public enum class AxisArrowStyle

メンバ

メンバ名 | 説明
Head | 矢印（初期値）
Heads | 両矢印
NoHeads | 矢印なし

解説

軸の矢印を示す列挙体です。

参照

Sakura.GW.AbstractLayer 名前空間


AxisSpec 列挙体

[image]

GraphWeaver For Visio ver.1.10
AxisSpec 列挙体
参照 フィードバックの送信
軸種別

名前空間 Sakura.GW.AbstractLayer
アセンブリ： Sakura.GW.AbstractLayer (Sakura.GW.AbstractLayer.dll 内)
バージョン: 1.1.0.0 (1.1.0.0)

構文

C#
public enum AxisSpec
Visual Basic (宣言)
Public Enumeration AxisSpec
Visual C++
public enum class AxisSpec

メンバ

メンバ名 | 説明
AxisX | X軸
AxisY | Y軸
AxisZ | Z軸（未対応）
Circle | 円軸（未対応）

解説

軸の種別を示す列挙体です。

未対応の軸種別は使用しないでください。

参照


BarStyle 列挙体

[image]

GraphWeaver For Visio ver.1.10
BarStyle 列挙体
参照 フィードバックの送信
棒形状

名前空間 Sakura.GW.AbstractLayer
アセンブリ： Sakura.GW.AbstractLayer (Sakura.GW.AbstractLayer.dll 内)
バージョン: 1.1.0.0 (1.1.0.0)

構文

C#
public enum BarStyle
Visual Basic (宣言)
Public Enumeration BarStyle
Visual C++
public enum class BarStyle

メンバ

メンバ名 | 説明
None | 未定義
Normal | 通常
Cumulative | 累積（未対応）
CumulativeRatio | 累積割合（未対応）

解説

グラフ形状が以下のグラフの時、データを表す棒の形状種別を示す列挙体です。
  • BarChart

参照

Sakura.GW.AbstractLayer..::.GraphWeaver_BarPack


BarType 列挙体

[image]

GraphWeaver For Visio ver.1.10
BarType 列挙体
参照 フィードバックの送信
棒表示方向

名前空間 Sakura.GW.AbstractLayer
アセンブリ： Sakura.GW.AbstractLayer (Sakura.GW.AbstractLayer.dll 内)
バージョン: 1.1.0.0 (1.1.0.0)

構文

C#
public enum BarType
Visual Basic (宣言)
Public Enumeration BarType
Visual C++
public enum class BarType

メンバ

メンバ名 | 説明
None | 未定義
Vertical | 縦棒
Horizontal | 横棒

解説

グラフ形状が以下のグラフの時、データを表す棒の表示方向を示す列挙体です。
  • BarChart

参照

Sakura.GW.AbstractLayer..::.GraphWeaver_BarPack


ColorIndex 列挙体

[image]

GraphWeaver For Visio ver.1.10
ColorIndex 列挙体
参照 フィードバックの送信
色インデックス

名前空間 Sakura.GW.AbstractLayer
アセンブリ： Sakura.GW.AbstractLayer (Sakura.GW.AbstractLayer.dll 内)
バージョン: 1.1.0.0 (1.1.0.0)

構文

C#
public enum ColorIndex
Visual Basic (宣言)
Public Enumeration ColorIndex
Visual C++
public enum class ColorIndex

メンバ

メンバ名 | 説明
None | 未定義
Transparence | 透明
White | 白
Black | 黒
Red | 赤
Green | 緑
Blue | 青
Yellow | 黄色
Brown | 茶色
Cyan | シアン
Magenta | マゼンタ

解説

色をインデックスとして定義します。

Noneは未設定時の初期値として使用されているため、指定時には使用できません。

Transparenceを指定すると透過処理されます。

参照

RGB色クラス


GraphType 列挙体

[image]

GraphWeaver For Visio ver.1.10
GraphType 列挙体
参照 フィードバックの送信
グラフ種別

名前空間 Sakura.GW.AbstractLayer
アセンブリ： Sakura.GW.AbstractLayer (Sakura.GW.AbstractLayer.dll 内)
バージョン: 1.1.0.0 (1.1.0.0)

構文

C#
public enum GraphType
Visual Basic (宣言)
Public Enumeration GraphType
Visual C++
public enum class GraphType

メンバ

メンバ名 | 説明
LineChart | 折れ線グラフ
BarChart | 棒グラフ
PieChart | 円グラフ（未対応）
CircularAreaChart | チャート（未対応）
MeterChart | 動的メータグラフ（未対応）
ExtendedChart1 | 拡張グラフ１（未対応）
ExtendedChart2 | 拡張グラフ２（未対応）
ExtendedChart3 | 拡張グラフ３（未対応）
ExtendedChart4 | 拡張グラフ４（未対応）
ExtendedChart5 | 拡張グラフ５（未対応）
ExtendedChart6 | 拡張グラフ６（未対応）
ExtendedChart7 | 拡張グラフ７（未対応）
ExtendedChart8 | 拡張グラフ８（未対応）
ExtendedChart9 | 拡張グラフ９（未対応）
ExtendedChart10 | 拡張グラフ１０（未対応）

解説

グラフの種別を表す列挙体です。

現在、円グラフ以下は未対応なので使用しないでください。

参照

Sakura.GW.AbstractLayer 名前空間
Sakura.GW.AbstractLayer..::.PointStyle
Sakura.GW.AbstractLayer..::.BarStyle
Sakura.GW.AbstractLayer..::.Quadrant


GraphWeaver_AxisPack クラス

[image]

GraphWeaver For Visio ver.1.10
GraphWeaver_AxisPack クラス
メンバ 使用例 参照 フィードバックの送信
軸情報設定クラス

名前空間 Sakura.GW.AbstractLayer
アセンブリ： Sakura.GW.AbstractLayer (Sakura.GW.AbstractLayer.dll 内)
バージョン: 1.1.0.0 (1.1.0.0)

構文

C#
public class GraphWeaver_AxisPack
Visual Basic (宣言)
Public Class GraphWeaver_AxisPack
Visual C++
public ref class GraphWeaver_AxisPack

解説

グラフの軸の属性を保持するクラス

使用例

軸種別をＸ軸に設定する。
CopyC#
GraphWeaver_AxisPack pack = new GraphWeaver_AxisPack();
pack.axisSpec = AxisSpec.AxisX;

継承階層

System..::.Object
Sakura.GW.AbstractLayer..::.GraphWeaver_AxisPack

参照

GraphWeaver_AxisPack メンバ


GraphWeaver_AxisPack メンバ

[image] [image]

GraphWeaver For Visio ver.1.10
GraphWeaver_AxisPack メンバ
GraphWeaver_AxisPack クラス コンストラクタ フィールド 参照 フィードバックの送信

GraphWeaver_AxisPack 型で公開されるメンバを以下の表に示します。

コンストラクタ

名前 | 説明
GraphWeaver_AxisPack | コンストラクタ

フィールド

名前 | 説明
additionalLine1 | 第1補助線属性
additionalLine2 | 第2補助線属性
arrowStyle | 矢印形式
axisColor | 軸色
axisSpec | 軸種別
bEnable | 有効フラグ
max | 最大値
min | 最小値
tickness | 軸太さ
title | 軸名称
titleAttr | 軸名称属性

参照

GraphWeaver_AxisPack クラス


GraphWeaver_AxisPack コンストラクタ

[image]

GraphWeaver For Visio ver.1.10
GraphWeaver_AxisPack コンストラクタ
GraphWeaver_AxisPack クラス 参照 フィードバックの送信
コンストラクタ

名前空間 Sakura.GW.AbstractLayer
アセンブリ： Sakura.GW.AbstractLayer (Sakura.GW.AbstractLayer.dll 内)
バージョン: 1.1.0.0 (1.1.0.0)

構文

C#
public GraphWeaver_AxisPack()
Visual Basic (宣言)
Public Sub New
Visual C++
public:
GraphWeaver_AxisPack()

参照

GraphWeaver_AxisPack クラス


GraphWeaver_AxisPack フィールド

[image] [image]

GraphWeaver For Visio ver.1.10
GraphWeaver_AxisPack フィールド
GraphWeaver_AxisPack クラス 参照 フィードバックの送信

GraphWeaver_AxisPack 型で公開されるメンバを以下の表に示します。

フィールド

名前 | 説明
additionalLine1 | 第1補助線属性
additionalLine2 | 第2補助線属性
arrowStyle | 矢印形式
axisColor | 軸色
axisSpec | 軸種別
bEnable | 有効フラグ
max | 最大値
min | 最小値
tickness | 軸太さ
title | 軸名称
titleAttr | 軸名称属性

参照

GraphWeaver_AxisPack クラス


additionalLine1 フィールド

[image]

GraphWeaver For Visio ver.1.10
GraphWeaver_AxisPack..::.additionalLine1 フィールド
GraphWeaver_AxisPack クラス 参照 フィードバックの送信
第1補助線属性

名前空間 Sakura.GW.AbstractLayer
アセンブリ： Sakura.GW.AbstractLayer (Sakura.GW.AbstractLayer.dll 内)
バージョン: 1.1.0.0 (1.1.0.0)

構文

C#
public GraphWeaver_AxisPack..::.Additional1 additionalLine1
Visual Basic (宣言)
Public additionalLine1 As GraphWeaver_AxisPack..::.Additional1
Visual C++
public:
GraphWeaver_AxisPack..::.Additional1 additionalLine1

解説

軸上に表示する補助線の属性です。

参照

GraphWeaver_AxisPack クラス


additionalLine2 フィールド

[image]

GraphWeaver For Visio ver.1.10
GraphWeaver_AxisPack..::.additionalLine2 フィールド
GraphWeaver_AxisPack クラス 参照 フィードバックの送信
第2補助線属性

名前空間 Sakura.GW.AbstractLayer
アセンブリ： Sakura.GW.AbstractLayer (Sakura.GW.AbstractLayer.dll 内)
バージョン: 1.1.0.0 (1.1.0.0)

構文

C#
public GraphWeaver_AxisPack..::.Additional2 additionalLine2
Visual Basic (宣言)
Public additionalLine2 As GraphWeaver_AxisPack..::.Additional2
Visual C++
public:
GraphWeaver_AxisPack..::.Additional2 additionalLine2

解説

第１補助線間を更に分割する補助線です。

参照

GraphWeaver_AxisPack クラス


arrowStyle フィールド

[image]

GraphWeaver For Visio ver.1.10
GraphWeaver_AxisPack..::.arrowStyle フィールド
GraphWeaver_AxisPack クラス 参照 フィードバックの送信
矢印形式

名前空間 Sakura.GW.AbstractLayer
アセンブリ： Sakura.GW.AbstractLayer (Sakura.GW.AbstractLayer.dll 内)
バージョン: 1.1.0.0 (1.1.0.0)

構文

C#
public AxisArrowStyle arrowStyle
Visual Basic (宣言)
Public arrowStyle As AxisArrowStyle
Visual C++
public:
AxisArrowStyle arrowStyle

解説

軸の矢印形式を表します。

参照

GraphWeaver_AxisPack クラス


axisColor フィールド

[image]

GraphWeaver For Visio ver.1.10
GraphWeaver_AxisPack..::.axisColor フィールド
GraphWeaver_AxisPack クラス 参照 フィードバックの送信
軸色

名前空間 Sakura.GW.AbstractLayer
アセンブリ： Sakura.GW.AbstractLayer (Sakura.GW.AbstractLayer.dll 内)
バージョン: 1.1.0.0 (1.1.0.0)

構文

C#
public RGB axisColor
Visual Basic (宣言)
Public axisColor As RGB
Visual C++
public:
RGB^ axisColor

解説

軸の色を表します。

参照

GraphWeaver_AxisPack クラス
Sakura.GW.AbstractLayer..::.RGB


axisSpec フィールド

[image]

GraphWeaver For Visio ver.1.10
GraphWeaver_AxisPack..::.axisSpec フィールド
GraphWeaver_AxisPack クラス 参照 フィードバックの送信
軸種別

名前空間 Sakura.GW.AbstractLayer
アセンブリ： Sakura.GW.AbstractLayer (Sakura.GW.AbstractLayer.dll 内)
バージョン: 1.1.0.0 (1.1.0.0)

構文

C#
public AxisSpec axisSpec
Visual Basic (宣言)
Public axisSpec As AxisSpec
Visual C++
public:
AxisSpec axisSpec

解説

軸種別を表します。

参照

GraphWeaver_AxisPack クラス


bEnable フィールド

[image]

GraphWeaver For Visio ver.1.10
GraphWeaver_AxisPack..::.bEnable フィールド
GraphWeaver_AxisPack クラス 参照 フィードバックの送信
有効フラグ

名前空間 Sakura.GW.AbstractLayer
アセンブリ： Sakura.GW.AbstractLayer (Sakura.GW.AbstractLayer.dll 内)
バージョン: 1.1.0.0 (1.1.0.0)

構文

C#
public bool bEnable
Visual Basic (宣言)
Public bEnable As Boolean
Visual C++
public:
bool bEnable

解説

trueを設定すると軸を表示し、falseで非表示にします。

参照

GraphWeaver_AxisPack クラス


max フィールド

[image]

GraphWeaver For Visio ver.1.10
GraphWeaver_AxisPack..::.max フィールド
GraphWeaver_AxisPack クラス 参照 フィードバックの送信
最大値

名前空間 Sakura.GW.AbstractLayer
アセンブリ： Sakura.GW.AbstractLayer (Sakura.GW.AbstractLayer.dll 内)
バージョン: 1.1.0.0 (1.1.0.0)

構文

C#
public double max
Visual Basic (宣言)
Public max As Double
Visual C++
public:
double max

解説

軸の最大値を表します。

参照

GraphWeaver_AxisPack クラス


min フィールド

[image]

GraphWeaver For Visio ver.1.10
GraphWeaver_AxisPack..::.min フィールド
GraphWeaver_AxisPack クラス 参照 フィードバックの送信
最小値

名前空間 Sakura.GW.AbstractLayer
アセンブリ： Sakura.GW.AbstractLayer (Sakura.GW.AbstractLayer.dll 内)
バージョン: 1.1.0.0 (1.1.0.0)

構文

C#
public double min
Visual Basic (宣言)
Public min As Double
Visual C++
public:
double min

解説

軸の最小値を表します。

参照

GraphWeaver_AxisPack クラス


tickness フィールド

[image]

GraphWeaver For Visio ver.1.10
GraphWeaver_AxisPack..::.tickness フィールド
GraphWeaver_AxisPack クラス 参照 フィードバックの送信
軸太さ

名前空間 Sakura.GW.AbstractLayer
アセンブリ： Sakura.GW.AbstractLayer (Sakura.GW.AbstractLayer.dll 内)
バージョン: 1.1.0.0 (1.1.0.0)

構文

C#
public double tickness
Visual Basic (宣言)
Public tickness As Double
Visual C++
public:
double tickness

解説

軸の太さを表します。

単位はグラフ単位設定に依存します。

参照

GraphWeaver_AxisPack クラス


title フィールド

[image]

GraphWeaver For Visio ver.1.10
GraphWeaver_AxisPack..::.title フィールド
GraphWeaver_AxisPack クラス 参照 フィードバックの送信
軸名称

名前空間 Sakura.GW.AbstractLayer
アセンブリ： Sakura.GW.AbstractLayer (Sakura.GW.AbstractLayer.dll 内)
バージョン: 1.1.0.0 (1.1.0.0)

構文

C#
public string title
Visual Basic (宣言)
Public title As String
Visual C++
public:
String^ title

解説

軸の名称として表示する文字列を表します。
表示したくない場合は、空欄にしてください。

参照

GraphWeaver_AxisPack クラス


titleAttr フィールド

[image]

GraphWeaver For Visio ver.1.10
GraphWeaver_AxisPack..::.titleAttr フィールド
GraphWeaver_AxisPack クラス 参照 フィードバックの送信
軸名称属性

名前空間 Sakura.GW.AbstractLayer
アセンブリ： Sakura.GW.AbstractLayer (Sakura.GW.AbstractLayer.dll 内)
バージョン: 1.1.0.0 (1.1.0.0)

構文

C#
public GraphWeaver_FontAttribute titleAttr
Visual Basic (宣言)
Public titleAttr As GraphWeaver_FontAttribute
Visual C++
public:
GraphWeaver_FontAttribute^ titleAttr

解説

軸名称の文字列に使用するフォント属性を表します。

参照

GraphWeaver_AxisPack クラス
Sakura.GW.AbstractLayer..::.GraphWeaver_FontAttribute


GraphWeaver_AxisPack.Additional1 構造体

[image]

GraphWeaver For Visio ver.1.10
GraphWeaver_AxisPack..::.Additional1 構造体
GraphWeaver_AxisPack クラス メンバ 参照 フィードバックの送信
第1補助線属性

名前空間 Sakura.GW.AbstractLayer
アセンブリ： Sakura.GW.AbstractLayer (Sakura.GW.AbstractLayer.dll 内)
バージョン: 1.1.0.0 (1.1.0.0)

構文

C#
public struct Additional1
Visual Basic (宣言)
Public Structure Additional1
Visual C++
public value class Additional1

解説

第１補助線の属性を保持する

参照

GraphWeaver_AxisPack..::.Additional1 メンバ


GraphWeaver_AxisPack.Additional1 メンバ

[image] [image]

GraphWeaver For Visio ver.1.10
GraphWeaver_AxisPack..::.Additional1 メンバ
GraphWeaver_AxisPack..::.Additional1 構造体 フィールド 参照 フィードバックの送信

軸情報設定クラス

GraphWeaver_AxisPack..::.Additional1 型で公開されるメンバを以下の表に示します。

フィールド

名前 | 説明
ticColor | 第1補助線色
ticFontAttr | 第1補助線数値属性
ticLength | 第1補助線長さ
tics | 第1補助線きざみ値
ticThickness | 第1補助線太さ

参照

GraphWeaver_AxisPack..::.Additional1 構造体


GraphWeaver_AxisPack.Additional1 フィールド

[image] [image]

GraphWeaver For Visio ver.1.10
GraphWeaver_AxisPack..::.Additional1 フィールド
GraphWeaver_AxisPack..::.Additional1 構造体 参照 フィードバックの送信

GraphWeaver_AxisPack..::.Additional1 型で公開されるメンバを以下の表に示します。

フィールド

名前 | 説明
ticColor | 第1補助線色
ticFontAttr | 第1補助線数値属性
ticLength | 第1補助線長さ
tics | 第1補助線きざみ値
ticThickness | 第1補助線太さ

参照

GraphWeaver_AxisPack..::.Additional1 構造体


ticColor フィールド

[image]

GraphWeaver For Visio ver.1.10
GraphWeaver_AxisPack..::.Additional1..::.ticColor フィールド
GraphWeaver_AxisPack..::.Additional1 構造体 参照 フィードバックの送信
第1補助線色

名前空間 Sakura.GW.AbstractLayer
アセンブリ： Sakura.GW.AbstractLayer (Sakura.GW.AbstractLayer.dll 内)
バージョン: 1.1.0.0 (1.1.0.0)

構文

C#
public RGB ticColor
Visual Basic (宣言)
Public ticColor As RGB
Visual C++
public:
RGB^ ticColor

解説

補助線の線色です。

参照

GraphWeaver_AxisPack..::.Additional1 構造体
Sakura.GW.AbstractLayer..::.RGB


ticFontAttr フィールド

[image]

GraphWeaver For Visio ver.1.10
GraphWeaver_AxisPack..::.Additional1..::.ticFontAttr フィールド
GraphWeaver_AxisPack..::.Additional1 構造体 参照 フィードバックの送信
第1補助線数値属性

名前空間 Sakura.GW.AbstractLayer
アセンブリ： Sakura.GW.AbstractLayer (Sakura.GW.AbstractLayer.dll 内)
バージョン: 1.1.0.0 (1.1.0.0)

構文

C#
public GraphWeaver_FontAttribute ticFontAttr
Visual Basic (宣言)
Public ticFontAttr As GraphWeaver_FontAttribute
Visual C++
public:
GraphWeaver_FontAttribute^ ticFontAttr

解説

補助線に表示される値を示す数値のフォント属性です。

参照

GraphWeaver_AxisPack..::.Additional1 構造体
Sakura.GW.AbstractLayer..::.GraphWeaver_FontAttribute


ticLength フィールド

[image]

GraphWeaver For Visio ver.1.10
GraphWeaver_AxisPack..::.Additional1..::.ticLength フィールド
GraphWeaver_AxisPack..::.Additional1 構造体 参照 フィードバックの送信
第1補助線長さ

名前空間 Sakura.GW.AbstractLayer
アセンブリ： Sakura.GW.AbstractLayer (Sakura.GW.AbstractLayer.dll 内)
バージョン: 1.1.0.0 (1.1.0.0)

構文

C#
public double ticLength
Visual Basic (宣言)
Public ticLength As Double
Visual C++
public:
double ticLength

解説

単位はグラフ設定の単位に依存します。

参照

GraphWeaver_AxisPack..::.Additional1 構造体


tics フィールド

[image]

GraphWeaver For Visio ver.1.10
GraphWeaver_AxisPack..::.Additional1..::.tics フィールド
GraphWeaver_AxisPack..::.Additional1 構造体 参照 フィードバックの送信
第1補助線きざみ値

名前空間 Sakura.GW.AbstractLayer
アセンブリ： Sakura.GW.AbstractLayer (Sakura.GW.AbstractLayer.dll 内)
バージョン: 1.1.0.0 (1.1.0.0)

構文

C#
public double tics
Visual Basic (宣言)
Public tics As Double
Visual C++
public:
double tics

解説

補助線を入れる間隔を表しています。０～軸の最大値まで有効です。
０を設定すると、補助線を表示しない設定になります。

単位はグラフ設定の単位に依存します。

参照

GraphWeaver_AxisPack..::.Additional1 構造体


ticThickness フィールド

[image]

GraphWeaver For Visio ver.1.10
GraphWeaver_AxisPack..::.Additional1..::.ticThickness フィールド
GraphWeaver_AxisPack..::.Additional1 構造体 参照 フィードバックの送信
第1補助線太さ

名前空間 Sakura.GW.AbstractLayer
アセンブリ： Sakura.GW.AbstractLayer (Sakura.GW.AbstractLayer.dll 内)
バージョン: 1.1.0.0 (1.1.0.0)

構文

C#
public double ticThickness
Visual Basic (宣言)
Public ticThickness As Double
Visual C++
public:
double ticThickness

解説

単位はグラフ設定の単位に依存します。

参照

GraphWeaver_AxisPack..::.Additional1 構造体


GraphWeaver_AxisPack.Additional2 構造体

[image]

GraphWeaver For Visio ver.1.10
GraphWeaver_AxisPack..::.Additional2 構造体
GraphWeaver_AxisPack クラス メンバ 参照 フィードバックの送信
第2補助線属性

名前空間 Sakura.GW.AbstractLayer
アセンブリ： Sakura.GW.AbstractLayer (Sakura.GW.AbstractLayer.dll 内)
バージョン: 1.1.0.0 (1.1.0.0)

構文

C#
public struct Additional2
Visual Basic (宣言)
Public Structure Additional2
Visual C++
public value class Additional2

解説

第２補助線の属性を保持する

参照

GraphWeaver_AxisPack..::.Additional2 メンバ


GraphWeaver_AxisPack.Additional2 メンバ

[image] [image]

GraphWeaver For Visio ver.1.10
GraphWeaver_AxisPack..::.Additional2 メンバ
GraphWeaver_AxisPack..::.Additional2 構造体 フィールド 参照 フィードバックの送信

軸情報設定クラス

GraphWeaver_AxisPack..::.Additional2 型で公開されるメンバを以下の表に示します。

フィールド

名前 | 説明
mTicColor | 第2補助線色
mTicLength | 第2補助線長さ
mTics | 第2補助線分割数
mTicThickness | 第2補助線太さ

参照

GraphWeaver_AxisPack..::.Additional2 構造体


GraphWeaver_AxisPack.Additional2 フィールド

[image] [image]

GraphWeaver For Visio ver.1.10
GraphWeaver_AxisPack..::.Additional2 フィールド
GraphWeaver_AxisPack..::.Additional2 構造体 参照 フィードバックの送信

GraphWeaver_AxisPack..::.Additional2 型で公開されるメンバを以下の表に示します。

フィールド

名前 | 説明
mTicColor | 第2補助線色
mTicLength | 第2補助線長さ
mTics | 第2補助線分割数
mTicThickness | 第2補助線太さ

参照

GraphWeaver_AxisPack..::.Additional2 構造体


mTicColor フィールド

[image]

GraphWeaver For Visio ver.1.10
GraphWeaver_AxisPack..::.Additional2..::.mTicColor フィールド
GraphWeaver_AxisPack..::.Additional2 構造体 参照 フィードバックの送信
第2補助線色

名前空間 Sakura.GW.AbstractLayer
アセンブリ： Sakura.GW.AbstractLayer (Sakura.GW.AbstractLayer.dll 内)
バージョン: 1.1.0.0 (1.1.0.0)

構文

C#
public RGB mTicColor
Visual Basic (宣言)
Public mTicColor As RGB
Visual C++
public:
RGB^ mTicColor

解説

補助線の線色です。

参照

GraphWeaver_AxisPack..::.Additional2 構造体
Sakura.GW.AbstractLayer..::.RGB


mTicLength フィールド

[image]

GraphWeaver For Visio ver.1.10
GraphWeaver_AxisPack..::.Additional2..::.mTicLength フィールド
GraphWeaver_AxisPack..::.Additional2 構造体 参照 フィードバックの送信
第2補助線長さ

名前空間 Sakura.GW.AbstractLayer
アセンブリ： Sakura.GW.AbstractLayer (Sakura.GW.AbstractLayer.dll 内)
バージョン: 1.1.0.0 (1.1.0.0)

構文

C#
public double mTicLength
Visual Basic (宣言)
Public mTicLength As Double
Visual C++
public:
double mTicLength

解説

単位はグラフ設定の単位に依存します。

参照

GraphWeaver_AxisPack..::.Additional2 構造体


mTics フィールド

[image]

GraphWeaver For Visio ver.1.10
GraphWeaver_AxisPack..::.Additional2..::.mTics フィールド
GraphWeaver_AxisPack..::.Additional2 構造体 参照 フィードバックの送信
第2補助線分割数

名前空間 Sakura.GW.AbstractLayer
アセンブリ： Sakura.GW.AbstractLayer (Sakura.GW.AbstractLayer.dll 内)
バージョン: 1.1.0.0 (1.1.0.0)

構文

C#
public int mTics
Visual Basic (宣言)
Public mTics As Integer
Visual C++
public:
int mTics

解説

第１補助線の分割数を表しています。２以下を設定すると、補助線を表示しない設定になります。

第１補助線が有効でない場合、第２補助線は無効となり表示されません。

参照

GraphWeaver_AxisPack..::.Additional2 構造体


mTicThickness フィールド

[image]

GraphWeaver For Visio ver.1.10
GraphWeaver_AxisPack..::.Additional2..::.mTicThickness フィールド
GraphWeaver_AxisPack..::.Additional2 構造体 参照 フィードバックの送信
第2補助線太さ

名前空間 Sakura.GW.AbstractLayer
アセンブリ： Sakura.GW.AbstractLayer (Sakura.GW.AbstractLayer.dll 内)
バージョン: 1.1.0.0 (1.1.0.0)

構文

C#
public double mTicThickness
Visual Basic (宣言)
Public mTicThickness As Double
Visual C++
public:
double mTicThickness

解説

単位はグラフ設定の単位に依存します。

参照

GraphWeaver_AxisPack..::.Additional2 構造体


GraphWeaver_BarPack クラス

[image]

GraphWeaver For Visio ver.1.10
GraphWeaver_BarPack クラス
メンバ 使用例 参照 フィードバックの送信
棒情報設定クラス

名前空間 Sakura.GW.AbstractLayer
アセンブリ： Sakura.GW.AbstractLayer (Sakura.GW.AbstractLayer.dll 内)
バージョン: 1.1.0.0 (1.1.0.0)

構文

C#
public class GraphWeaver_BarPack
Visual Basic (宣言)
Public Class GraphWeaver_BarPack
Visual C++
public ref class GraphWeaver_BarPack

解説

グラフ種別がBarChartの時、データを表す棒の属性を保持するクラス

使用例

棒形状を通常の形式に設定する。
CopyC#
GraphWeaver_Barpack pack = new GraphWeaver_Barpack();
pack.stype = BarStyle.Normal;

継承階層

System..::.Object
Sakura.GW.AbstractLayer..::.GraphWeaver_BarPack

参照

GraphWeaver_BarPack メンバ


GraphWeaver_BarPack メンバ

[image] [image]

GraphWeaver For Visio ver.1.10
GraphWeaver_BarPack メンバ
GraphWeaver_BarPack クラス コンストラクタ フィールド 参照 フィードバックの送信

GraphWeaver_BarPack 型で公開されるメンバを以下の表に示します。

コンストラクタ

名前 | 説明
GraphWeaver_BarPack | GraphWeaver_BarPack クラスの新しいインスタンスを初期化します。

フィールド

名前 | 説明
barColor | 棒色
style | 棒形状
type | 棒タイプ
width | 棒幅

参照

GraphWeaver_BarPack クラス


GraphWeaver_BarPack コンストラクタ

[image]

GraphWeaver For Visio ver.1.10
GraphWeaver_BarPack コンストラクタ
GraphWeaver_BarPack クラス 参照 フィードバックの送信
GraphWeaver_BarPack クラスの新しいインスタンスを初期化します。

名前空間 Sakura.GW.AbstractLayer
アセンブリ： Sakura.GW.AbstractLayer (Sakura.GW.AbstractLayer.dll 内)
バージョン: 1.1.0.0 (1.1.0.0)

構文

C#
public GraphWeaver_BarPack()
Visual Basic (宣言)
Public Sub New
Visual C++
public:
GraphWeaver_BarPack()

参照

GraphWeaver_BarPack クラス


GraphWeaver_BarPack フィールド

[image] [image]

GraphWeaver For Visio ver.1.10
GraphWeaver_BarPack フィールド
GraphWeaver_BarPack クラス 参照 フィードバックの送信

GraphWeaver_BarPack 型で公開されるメンバを以下の表に示します。

フィールド

名前 | 説明
barColor | 棒色
style | 棒形状
type | 棒タイプ
width | 棒幅

参照

GraphWeaver_BarPack クラス


barColor フィールド

[image]

GraphWeaver For Visio ver.1.10
GraphWeaver_BarPack..::.barColor フィールド
GraphWeaver_BarPack クラス 参照 フィードバックの送信
棒色

名前空間 Sakura.GW.AbstractLayer
アセンブリ： Sakura.GW.AbstractLayer (Sakura.GW.AbstractLayer.dll 内)
バージョン: 1.1.0.0 (1.1.0.0)

構文

C#
public RGB barColor
Visual Basic (宣言)
Public barColor As RGB
Visual C++
public:
RGB^ barColor

参照

GraphWeaver_BarPack クラス


style フィールド

[image]

GraphWeaver For Visio ver.1.10
GraphWeaver_BarPack..::.style フィールド
GraphWeaver_BarPack クラス 参照 フィードバックの送信
棒形状

名前空間 Sakura.GW.AbstractLayer
アセンブリ： Sakura.GW.AbstractLayer (Sakura.GW.AbstractLayer.dll 内)
バージョン: 1.1.0.0 (1.1.0.0)

構文

C#
public BarStyle style
Visual Basic (宣言)
Public style As BarStyle
Visual C++
public:
BarStyle style

参照

GraphWeaver_BarPack クラス


type フィールド

[image]

GraphWeaver For Visio ver.1.10
GraphWeaver_BarPack..::.type フィールド
GraphWeaver_BarPack クラス 参照 フィードバックの送信
棒タイプ

名前空間 Sakura.GW.AbstractLayer
アセンブリ： Sakura.GW.AbstractLayer (Sakura.GW.AbstractLayer.dll 内)
バージョン: 1.1.0.0 (1.1.0.0)

構文

C#
public BarType type
Visual Basic (宣言)
Public type As BarType
Visual C++
public:
BarType type

参照

GraphWeaver_BarPack クラス


width フィールド

[image]

GraphWeaver For Visio ver.1.10
GraphWeaver_BarPack..::.width フィールド
GraphWeaver_BarPack クラス 参照 フィードバックの送信
棒幅

名前空間 Sakura.GW.AbstractLayer
アセンブリ： Sakura.GW.AbstractLayer (Sakura.GW.AbstractLayer.dll 内)
バージョン: 1.1.0.0 (1.1.0.0)

構文

C#
public double width
Visual Basic (宣言)
Public width As Double
Visual C++
public:
double width

参照

GraphWeaver_BarPack クラス


GraphWeaver_DataInputSpec 列挙体

[image]

GraphWeaver For Visio ver.1.10
GraphWeaver_DataInputSpec 列挙体
参照 フィードバックの送信
データ入力種別

名前空間 Sakura.GW.AbstractLayer
アセンブリ： Sakura.GW.AbstractLayer (Sakura.GW.AbstractLayer.dll 内)
バージョン: 1.1.0.0 (1.1.0.0)

構文

C#
public enum GraphWeaver_DataInputSpec
Visual Basic (宣言)
Public Enumeration GraphWeaver_DataInputSpec
Visual C++
public enum class GraphWeaver_DataInputSpec

メンバ

メンバ名 | 説明
None | 未定義
File | ファイル
RowData | Rowデータ

解説

データの入力種別を示す列挙体です。

GraphWeaverData.SetDataFileで設定された場合はFile、GraphWeaverData.SetRowDataで直接設定された場合はRowDataになります。

参照

Sakura.GW.AbstractLayer..::.GraphWeaverData


GraphWeaver_DataType 列挙体

[image]

GraphWeaver For Visio ver.1.10
GraphWeaver_DataType 列挙体
参照 フィードバックの送信
入力データファイルタイプ

名前空間 Sakura.GW.AbstractLayer
アセンブリ： Sakura.GW.AbstractLayer (Sakura.GW.AbstractLayer.dll 内)
バージョン: 1.1.0.0 (1.1.0.0)

構文

C#
public enum GraphWeaver_DataType
Visual Basic (宣言)
Public Enumeration GraphWeaver_DataType
Visual C++
public enum class GraphWeaver_DataType

メンバ

メンバ名 | 説明
None | 未定義
CsvFile | CSVファイル
BinaryFile | バイナリーファイル（未対応）
ExtendedFile1 | 拡張形式１（未対応）
ExtendedFile2 | 拡張形式２（未対応）
ExtendedFile3 | 拡張形式３（未対応）
ExtendedFile4 | 拡張形式４（未対応）
ExtendedFile5 | 拡張形式５（未対応）
ExtendedFile6 | 拡張形式６（未対応）
ExtendedFile7 | 拡張形式７（未対応）
ExtendedFile8 | 拡張形式８（未対応）
ExtendedFile9 | 拡張形式９（未対応）
ExtendedFile10 | 拡張形式１０（未対応）

解説

GraphWeaverData.SetDataFileで入力ファイルを設定した時のファイルの形式を示す列挙体です。

参照


GraphWeaver_FontAttribute クラス

[image]

GraphWeaver For Visio ver.1.10
GraphWeaver_FontAttribute クラス
メンバ 参照 フィードバックの送信
フォント属性

名前空間 Sakura.GW.AbstractLayer
アセンブリ： Sakura.GW.AbstractLayer (Sakura.GW.AbstractLayer.dll 内)
バージョン: 1.1.0.0 (1.1.0.0)

構文

C#
public class GraphWeaver_FontAttribute
Visual Basic (宣言)
Public Class GraphWeaver_FontAttribute
Visual C++
public ref class GraphWeaver_FontAttribute

解説

文字フォントの属性クラスです。フォントサイズ、フォント色等の設定を保持します。
フォントサイズにグラフ設定の単位で表す値を設定する場合は、fontSizeプロパティーに設定してください。
また、フォントサイズをポイント(pt)で指定する場合は、fontSizePointプロパティーに設定してください。
文字色に透明色を指定すると、文字が透明になります。(なお、Visio上では描画されません）

継承階層

System..::.Object
Sakura.GW.AbstractLayer..::.GraphWeaver_FontAttribute

参照

GraphWeaver_FontAttribute メンバ
Sakura.GW.AbstractLayer 名前空間
GraphWeaverData..::.SetGraphTitle(String, GraphWeaver_FontAttribute)


GraphWeaver_FontAttribute メンバ

[image] [image]

GraphWeaver For Visio ver.1.10
GraphWeaver_FontAttribute メンバ
GraphWeaver_FontAttribute クラス コンストラクタ フィールド プロパティ 参照 フィードバックの送信

GraphWeaver_FontAttribute 型で公開されるメンバを以下の表に示します。

コンストラクタ

名前 | 説明
GraphWeaver_FontAttribute | GraphWeaver_FontAttribute クラスの新しいインスタンスを初期化します。

フィールド

名前 | 説明
fontColor | 文字色
fontSize | 文字サイズ

プロパティ

名前 | 説明
fontSizePoint | 文字サイズ(pt単位)

参照

GraphWeaver_FontAttribute クラス


GraphWeaver_FontAttribute コンストラクタ

[image]

GraphWeaver For Visio ver.1.10
GraphWeaver_FontAttribute コンストラクタ
GraphWeaver_FontAttribute クラス 参照 フィードバックの送信
GraphWeaver_FontAttribute クラスの新しいインスタンスを初期化します。

名前空間 Sakura.GW.AbstractLayer
アセンブリ： Sakura.GW.AbstractLayer (Sakura.GW.AbstractLayer.dll 内)
バージョン: 1.1.0.0 (1.1.0.0)

構文

C#
public GraphWeaver_FontAttribute()
Visual Basic (宣言)
Public Sub New
Visual C++
public:
GraphWeaver_FontAttribute()

参照

GraphWeaver_FontAttribute クラス


GraphWeaver_FontAttribute フィールド

[image] [image]

GraphWeaver For Visio ver.1.10
GraphWeaver_FontAttribute フィールド
GraphWeaver_FontAttribute クラス 参照 フィードバックの送信

GraphWeaver_FontAttribute 型で公開されるメンバを以下の表に示します。

フィールド

名前 | 説明
fontColor | 文字色
fontSize | 文字サイズ

参照

GraphWeaver_FontAttribute クラス


fontColor フィールド

[image]

GraphWeaver For Visio ver.1.10
GraphWeaver_FontAttribute..::.fontColor フィールド
GraphWeaver_FontAttribute クラス 参照 フィードバックの送信
文字色

名前空間 Sakura.GW.AbstractLayer
アセンブリ： Sakura.GW.AbstractLayer (Sakura.GW.AbstractLayer.dll 内)
バージョン: 1.1.0.0 (1.1.0.0)

構文

C#
public RGB fontColor
Visual Basic (宣言)
Public fontColor As RGB
Visual C++
public:
RGB^ fontColor

解説

Visioでは透明色を指定すると、文字が表示されなくなります。

参照

GraphWeaver_FontAttribute クラス


fontSize フィールド

[image]

GraphWeaver For Visio ver.1.10
GraphWeaver_FontAttribute..::.fontSize フィールド
GraphWeaver_FontAttribute クラス 参照 フィードバックの送信
文字サイズ

名前空間 Sakura.GW.AbstractLayer
アセンブリ： Sakura.GW.AbstractLayer (Sakura.GW.AbstractLayer.dll 内)
バージョン: 1.1.0.0 (1.1.0.0)

構文

C#
public double fontSize
Visual Basic (宣言)
Public fontSize As Double
Visual C++
public:
double fontSize

参照

GraphWeaver_FontAttribute クラス


GraphWeaver_FontAttribute プロパティ

[image] [image]

GraphWeaver For Visio ver.1.10
GraphWeaver_FontAttribute プロパティ
GraphWeaver_FontAttribute クラス 参照 フィードバックの送信

GraphWeaver_FontAttribute 型で公開されるメンバを以下の表に示します。

プロパティ

名前 | 説明
fontSizePoint | 文字サイズ(pt単位)

参照

GraphWeaver_FontAttribute クラス


fontSizePoint プロパティ

[image]

GraphWeaver For Visio ver.1.10
GraphWeaver_FontAttribute..::.fontSizePoint プロパティ
GraphWeaver_FontAttribute クラス 参照 フィードバックの送信
文字サイズ(pt単位)

名前空間 Sakura.GW.AbstractLayer
アセンブリ： Sakura.GW.AbstractLayer (Sakura.GW.AbstractLayer.dll 内)
バージョン: 1.1.0.0 (1.1.0.0)

構文

C#
public double fontSizePoint { get; set; }
Visual Basic (宣言)
Public Property fontSizePoint As Double
Visual C++
public:
property double fontSizePoint {
    double get ();
    void set (double value);
}

参照

GraphWeaver_FontAttribute クラス


GraphWeaver_PointPack クラス

[image]

GraphWeaver For Visio ver.1.10
GraphWeaver_PointPack クラス
メンバ 使用例 参照 フィードバックの送信
点情報設定クラス

名前空間 Sakura.GW.AbstractLayer
アセンブリ： Sakura.GW.AbstractLayer (Sakura.GW.AbstractLayer.dll 内)
バージョン: 1.1.0.0 (1.1.0.0)

構文

C#
public class GraphWeaver_PointPack
Visual Basic (宣言)
Public Class GraphWeaver_PointPack
Visual C++
public ref class GraphWeaver_PointPack

解説

グラフ種別がLineChartの時、データを表す点の属性を保持するクラス

使用例

点形状を星型に設定する。
CopyC#
GraphWeaver_PointPack pack = new GraphWeaver_PointPack();
pack.stype = PointStyle.Star;

継承階層

System..::.Object
Sakura.GW.AbstractLayer..::.GraphWeaver_PointPack

参照

GraphWeaver_PointPack メンバ


GraphWeaver_PointPack メンバ

[image] [image]

GraphWeaver For Visio ver.1.10
GraphWeaver_PointPack メンバ
GraphWeaver_PointPack クラス コンストラクタ フィールド 参照 フィードバックの送信

GraphWeaver_PointPack 型で公開されるメンバを以下の表に示します。

コンストラクタ

名前 | 説明
GraphWeaver_PointPack | GraphWeaver_PointPack クラスの新しいインスタンスを初期化します。

フィールド

名前 | 説明
bConnect | 線接続フラグ
lineColor | 線色
lineTickness | 線太さ
pointColor | 点色
size | 点サイズ
style | 点形状

参照

GraphWeaver_PointPack クラス


GraphWeaver_PointPack コンストラクタ

[image]

GraphWeaver For Visio ver.1.10
GraphWeaver_PointPack コンストラクタ
GraphWeaver_PointPack クラス 参照 フィードバックの送信
GraphWeaver_PointPack クラスの新しいインスタンスを初期化します。

名前空間 Sakura.GW.AbstractLayer
アセンブリ： Sakura.GW.AbstractLayer (Sakura.GW.AbstractLayer.dll 内)
バージョン: 1.1.0.0 (1.1.0.0)

構文

C#
public GraphWeaver_PointPack()
Visual Basic (宣言)
Public Sub New
Visual C++
public:
GraphWeaver_PointPack()

参照

GraphWeaver_PointPack クラス


GraphWeaver_PointPack フィールド

[image] [image]

GraphWeaver For Visio ver.1.10
GraphWeaver_PointPack フィールド
GraphWeaver_PointPack クラス 参照 フィードバックの送信

GraphWeaver_PointPack 型で公開されるメンバを以下の表に示します。

フィールド

名前 | 説明
bConnect | 線接続フラグ
lineColor | 線色
lineTickness | 線太さ
pointColor | 点色
size | 点サイズ
style | 点形状

参照

GraphWeaver_PointPack クラス


bConnect フィールド

[image]

GraphWeaver For Visio ver.1.10
GraphWeaver_PointPack..::.bConnect フィールド
GraphWeaver_PointPack クラス 参照 フィードバックの送信
線接続フラグ

名前空間 Sakura.GW.AbstractLayer
アセンブリ： Sakura.GW.AbstractLayer (Sakura.GW.AbstractLayer.dll 内)
バージョン: 1.1.0.0 (1.1.0.0)

構文

C#
public bool bConnect
Visual Basic (宣言)
Public bConnect As Boolean
Visual C++
public:
bool bConnect

参照

GraphWeaver_PointPack クラス


lineColor フィールド

[image]

GraphWeaver For Visio ver.1.10
GraphWeaver_PointPack..::.lineColor フィールド
GraphWeaver_PointPack クラス 参照 フィードバックの送信
線色

名前空間 Sakura.GW.AbstractLayer
アセンブリ： Sakura.GW.AbstractLayer (Sakura.GW.AbstractLayer.dll 内)
バージョン: 1.1.0.0 (1.1.0.0)

構文

C#
public RGB lineColor
Visual Basic (宣言)
Public lineColor As RGB
Visual C++
public:
RGB^ lineColor

参照

GraphWeaver_PointPack クラス


lineTickness フィールド

[image]

GraphWeaver For Visio ver.1.10
GraphWeaver_PointPack..::.lineTickness フィールド
GraphWeaver_PointPack クラス 参照 フィードバックの送信
線太さ

名前空間 Sakura.GW.AbstractLayer
アセンブリ： Sakura.GW.AbstractLayer (Sakura.GW.AbstractLayer.dll 内)
バージョン: 1.1.0.0 (1.1.0.0)

構文

C#
public double lineTickness
Visual Basic (宣言)
Public lineTickness As Double
Visual C++
public:
double lineTickness

参照

GraphWeaver_PointPack クラス


pointColor フィールド

[image]

GraphWeaver For Visio ver.1.10
GraphWeaver_PointPack..::.pointColor フィールド
GraphWeaver_PointPack クラス 参照 フィードバックの送信
点色

名前空間 Sakura.GW.AbstractLayer
アセンブリ： Sakura.GW.AbstractLayer (Sakura.GW.AbstractLayer.dll 内)
バージョン: 1.1.0.0 (1.1.0.0)

構文

C#
public RGB pointColor
Visual Basic (宣言)
Public pointColor As RGB
Visual C++
public:
RGB^ pointColor

参照

GraphWeaver_PointPack クラス


size フィールド

[image]

GraphWeaver For Visio ver.1.10
GraphWeaver_PointPack..::.size フィールド
GraphWeaver_PointPack クラス 参照 フィードバックの送信
点サイズ

名前空間 Sakura.GW.AbstractLayer
アセンブリ： Sakura.GW.AbstractLayer (Sakura.GW.AbstractLayer.dll 内)
バージョン: 1.1.0.0 (1.1.0.0)

構文

C#
public double size
Visual Basic (宣言)
Public size As Double
Visual C++
public:
double size

参照

GraphWeaver_PointPack クラス


style フィールド

[image]

GraphWeaver For Visio ver.1.10
GraphWeaver_PointPack..::.style フィールド
GraphWeaver_PointPack クラス 参照 フィードバックの送信
点形状

名前空間 Sakura.GW.AbstractLayer
アセンブリ： Sakura.GW.AbstractLayer (Sakura.GW.AbstractLayer.dll 内)
バージョン: 1.1.0.0 (1.1.0.0)

構文

C#
public PointStyle style
Visual Basic (宣言)
Public style As PointStyle
Visual C++
public:
PointStyle style

参照

GraphWeaver_PointPack クラス


GraphWeaver_TargetSeries 列挙体

[image]

GraphWeaver For Visio ver.1.10
GraphWeaver_TargetSeries 列挙体
参照 フィードバックの送信
対象系列種別

名前空間 Sakura.GW.AbstractLayer
アセンブリ： Sakura.GW.AbstractLayer (Sakura.GW.AbstractLayer.dll 内)
バージョン: 1.1.0.0 (1.1.0.0)

構文

C#
public enum GraphWeaver_TargetSeries
Visual Basic (宣言)
Public Enumeration GraphWeaver_TargetSeries
Visual C++
public enum class GraphWeaver_TargetSeries

メンバ

メンバ名 | 説明
Indivisual | 個別系列
ALL | 系列全体

解説

処理対象となる系列が個別か全体化を示す列挙体です。

参照


GraphWeaverData クラス

[image]

GraphWeaver For Visio ver.1.10
GraphWeaverData クラス
メンバ 参照 フィードバックの送信
GraphWeaver設定クラス

名前空間 Sakura.GW.AbstractLayer
アセンブリ： Sakura.GW.AbstractLayer (Sakura.GW.AbstractLayer.dll 内)
バージョン: 1.1.0.0 (1.1.0.0)

構文

C#
public class GraphWeaverData
Visual Basic (宣言)
Public Class GraphWeaverData
Visual C++
public ref class GraphWeaverData

継承階層

System..::.Object
Sakura.GW.AbstractLayer..::.GraphWeaverData

参照

GraphWeaverData メンバ


GraphWeaverData メンバ

[image] [image]

GraphWeaver For Visio ver.1.10
GraphWeaverData メンバ
GraphWeaverData クラス コンストラクタ メソッド 参照 フィードバックの送信

GraphWeaverData 型で公開されるメンバを以下の表に示します。

コンストラクタ

名前 | 説明
GraphWeaverData | コンストラクタ

メソッド

名前 | 説明
CopyTo | 設定を内部値にコピーする
GetCommand | 実行コマンドを取得する
GetDataRowData | オーバーロードされます。
GetPageName | 対象ページ名取得
SetCommand | 実行コマンドを設定する
SetDataFile | オーバーロードされます。
SetDataRowData | オーバーロードされます。
SetDataSeriesNo | 入力データの系列最大番号設定
SetDisableGraphBat | 棒無効設定
SetDisableGraphPoint | 点無効設定
SetDocumentFile | 出力ドキュメント設定
SetGraphAxis | 軸一般設定
SetGraphAxisDetail | 軸詳細設定
SetGraphAxisPack | 軸一括設定
SetGraphBar | オーバーロードされます。
SetGraphImageLimit | 描画象限設定
SetGraphPoint | オーバーロードされます。
SetGraphSize | グラフ情報設定
SetGraphTitle | グラフタイトル設定
SetPage | ページ情報設定

参照

GraphWeaverData クラス


GraphWeaverData コンストラクタ

[image]

GraphWeaver For Visio ver.1.10
GraphWeaverData コンストラクタ
GraphWeaverData クラス 参照 フィードバックの送信
コンストラクタ

名前空間 Sakura.GW.AbstractLayer
アセンブリ： Sakura.GW.AbstractLayer (Sakura.GW.AbstractLayer.dll 内)
バージョン: 1.1.0.0 (1.1.0.0)

構文

C#
public GraphWeaverData()
Visual Basic (宣言)
Public Sub New
Visual C++
public:
GraphWeaverData()

参照

GraphWeaverData クラス


GraphWeaverData メソッド

[image] [image]

GraphWeaver For Visio ver.1.10
GraphWeaverData メソッド
GraphWeaverData クラス 参照 フィードバックの送信

GraphWeaverData 型で公開されるメンバを以下の表に示します。

メソッド

名前 | 説明
CopyTo | 設定を内部値にコピーする
GetCommand | 実行コマンドを取得する
GetDataRowData | オーバーロードされます。
GetPageName | 対象ページ名取得
SetCommand | 実行コマンドを設定する
SetDataFile | オーバーロードされます。
SetDataRowData | オーバーロードされます。
SetDataSeriesNo | 入力データの系列最大番号設定
SetDisableGraphBat | 棒無効設定
SetDisableGraphPoint | 点無効設定
SetDocumentFile | 出力ドキュメント設定
SetGraphAxis | 軸一般設定
SetGraphAxisDetail | 軸詳細設定
SetGraphAxisPack | 軸一括設定
SetGraphBar | オーバーロードされます。
SetGraphImageLimit | 描画象限設定
SetGraphPoint | オーバーロードされます。
SetGraphSize | グラフ情報設定
SetGraphTitle | グラフタイトル設定
SetPage | ページ情報設定

参照

GraphWeaverData クラス


CopyTo メソッド

[image]

GraphWeaver For Visio ver.1.10
GraphWeaverData..::.CopyTo メソッド
GraphWeaverData クラス 参照 フィードバックの送信
設定を内部値にコピーする

名前空間 Sakura.GW.AbstractLayer
アセンブリ： Sakura.GW.AbstractLayer (Sakura.GW.AbstractLayer.dll 内)
バージョン: 1.1.0.0 (1.1.0.0)

構文

C#
public void CopyTo(
    Object documentInfo,
    Object pageInfo
)
Visual Basic (宣言)
Public Sub CopyTo ( _
    documentInfo As Object, _
    pageInfo As Object _
)
Visual C++
public:
void CopyTo(
    Object^ documentInfo,
    Object^ pageInfo
)

パラメータ

documentInfo
型：System..::.Object
コピー先ドキュメント情報
pageInfo
型：System..::.Object
コピー先シート情報

解説

ライブラリ内部で使用しているので、使用しないでください。

参照

GraphWeaverData クラス


GetCommand メソッド

[image]

GraphWeaver For Visio ver.1.10
GraphWeaverData..::.GetCommand メソッド
GraphWeaverData クラス 参照 フィードバックの送信
実行コマンドを取得する

名前空間 Sakura.GW.AbstractLayer
アセンブリ： Sakura.GW.AbstractLayer (Sakura.GW.AbstractLayer.dll 内)
バージョン: 1.1.0.0 (1.1.0.0)

構文

C#
public GraphWeaverData..::.CommandID GetCommand()
Visual Basic (宣言)
Public Function GetCommand As GraphWeaverData..::.CommandID
Visual C++
public:
GraphWeaverData..::.CommandID GetCommand()

戻り値

型：GraphWeaverData..::.CommandID
実行コマンドID

解説

設定されているコマンドIDを取得します。

参照

GraphWeaverData クラス
Sakura.GW.AbstractLayer..::.GraphWeaverData..::.CommandID


GetDataRowData メソッド

[image] [image]

GraphWeaver For Visio ver.1.10
GraphWeaverData..::.GetDataRowData メソッド
GraphWeaverData クラス 参照 フィードバックの送信

オーバーロードの一覧

名前 | 説明
GetDataRowData()()() | 入力Rowデータ取得
GetDataRowData(Int32) | 入力Rowデータ取得

参照

GraphWeaverData クラス
GraphWeaverData メンバ


GetDataRowData メソッド

[image]

GraphWeaver For Visio ver.1.10
GraphWeaverData..::.GetDataRowData メソッド
GraphWeaverData クラス 参照 フィードバックの送信
入力Rowデータ取得

名前空間 Sakura.GW.AbstractLayer
アセンブリ： Sakura.GW.AbstractLayer (Sakura.GW.AbstractLayer.dll 内)
バージョン: 1.1.0.0 (1.1.0.0)

構文

C#
public List<Point> GetDataRowData()
Visual Basic (宣言)
Public Function GetDataRowData As List(Of Point)
Visual C++
public:
List<Point>^ GetDataRowData()

戻り値

型：List<(Of <(T>)>)
系列番号０の入力Rowデータリスト。リストの要素はPoint。

解説

系列番号０の入力データを取得します。
データ種別としてファイルが指定されていた場合、読み込み処理が完了していれば正しく取得できます。
データ種別としてRowデータが指定されていた場合、現在指定されているデータが取得できます。

参照

GraphWeaverData クラス
GetDataRowData オーバーロード


GetDataRowData メソッド (Int32)

[image]

GraphWeaver For Visio ver.1.10
GraphWeaverData..::.GetDataRowData メソッド (Int32)
GraphWeaverData クラス 参照 フィードバックの送信
入力Rowデータ取得

名前空間 Sakura.GW.AbstractLayer
アセンブリ： Sakura.GW.AbstractLayer (Sakura.GW.AbstractLayer.dll 内)
バージョン: 1.1.0.0 (1.1.0.0)

構文

C#
public List<Point> GetDataRowData(
    int series
)
Visual Basic (宣言)
Public Function GetDataRowData ( _
    series As Integer _
) As List(Of Point)
Visual C++
public:
List<Point>^ GetDataRowData(
    int series
)

パラメータ

series
型：System..::.Int32
系列数

戻り値

型：List<(Of <(T>)>)
系列番号０の入力Rowデータリスト。リストの要素はPoint。

解説

系列番号を指定しての入力データを取得します。
データ種別としてファイルが指定されていた場合、読み込み処理が完了していれば正しく取得できます。
データ種別としてRowデータが指定されていた場合、現在指定されているデータが取得できます。 系列番号に使用できる値は、０～SetDataSeriesNoで設定した最大値－１です。

参照

GraphWeaverData クラス
GetDataRowData オーバーロード


GetPageName メソッド

[image]

GraphWeaver For Visio ver.1.10
GraphWeaverData..::.GetPageName メソッド
GraphWeaverData クラス 参照 フィードバックの送信
対象ページ名取得

名前空間 Sakura.GW.AbstractLayer
アセンブリ： Sakura.GW.AbstractLayer (Sakura.GW.AbstractLayer.dll 内)
バージョン: 1.1.0.0 (1.1.0.0)

構文

C#
public string GetPageName()
Visual Basic (宣言)
Public Function GetPageName As String
Visual C++
public:
String^ GetPageName()

戻り値

型：String
対象ページのページ名。

参照

GraphWeaverData クラス


SetCommand メソッド

[image]

GraphWeaver For Visio ver.1.10
GraphWeaverData..::.SetCommand メソッド
GraphWeaverData クラス 参照 フィードバックの送信
実行コマンドを設定する

名前空間 Sakura.GW.AbstractLayer
アセンブリ： Sakura.GW.AbstractLayer (Sakura.GW.AbstractLayer.dll 内)
バージョン: 1.1.0.0 (1.1.0.0)

構文

C#
public void SetCommand(
    GraphWeaverData..::.CommandID id
)
Visual Basic (宣言)
Public Sub SetCommand ( _
    id As GraphWeaverData..::.CommandID _
)
Visual C++
public:
void SetCommand(
    GraphWeaverData..::.CommandID id
)

パラメータ

id
型：Sakura.GW.AbstractLayer..::.GraphWeaverData..::.CommandID
コマンドID

解説

実行コマンドIDにより、実行する処理を設定します。

参照

GraphWeaverData クラス
Sakura.GW.AbstractLayer..::.GraphWeaverData..::.CommandID


SetDataFile メソッド

[image] [image]

GraphWeaver For Visio ver.1.10
GraphWeaverData..::.SetDataFile メソッド
GraphWeaverData クラス 参照 フィードバックの送信

オーバーロードの一覧

名前 | 説明
SetDataFile(String, GraphWeaver_DataType) | 入力データファイル設定
SetDataFile(Int32, String, GraphWeaver_DataType) | 入力データファイル設定

参照

GraphWeaverData クラス
GraphWeaverData メンバ


SetDataFile メソッド (String, GraphWeaver_DataType)

[image]

GraphWeaver For Visio ver.1.10
GraphWeaverData..::.SetDataFile メソッド (String, GraphWeaver_DataType)
GraphWeaverData クラス 参照 フィードバックの送信
入力データファイル設定

名前空間 Sakura.GW.AbstractLayer
アセンブリ： Sakura.GW.AbstractLayer (Sakura.GW.AbstractLayer.dll 内)
バージョン: 1.1.0.0 (1.1.0.0)

構文

C#
public void SetDataFile(
    string fileFullPath,
    GraphWeaver_DataType type
)
Visual Basic (宣言)
Public Sub SetDataFile ( _
    fileFullPath As String, _
    type As GraphWeaver_DataType _
)
Visual C++
public:
void SetDataFile(
    String^ fileFullPath,
    GraphWeaver_DataType type
)

パラメータ

fileFullPath
型：System..::.String
フルパス名
type
型：Sakura.GW.AbstractLayer..::.GraphWeaver_DataType
ファイル種別

解説

系列番号０の入力データとしてファイルを使用するよう設定します。

フルパス名にはドライブ名、ファイル名を含む文字列で指定してください。

参照

GraphWeaverData クラス
SetDataFile オーバーロード


SetDataFile メソッド (Int32, String, GraphWeaver_DataType)

[image]

GraphWeaver For Visio ver.1.10
GraphWeaverData..::.SetDataFile メソッド (Int32, String, GraphWeaver_DataType)
GraphWeaverData クラス 参照 フィードバックの送信
入力データファイル設定

名前空間 Sakura.GW.AbstractLayer
アセンブリ： Sakura.GW.AbstractLayer (Sakura.GW.AbstractLayer.dll 内)
バージョン: 1.1.0.0 (1.1.0.0)

構文

C#
public void SetDataFile(
    int series,
    string fileFullPath,
    GraphWeaver_DataType type
)
Visual Basic (宣言)
Public Sub SetDataFile ( _
    series As Integer, _
    fileFullPath As String, _
    type As GraphWeaver_DataType _
)
Visual C++
public:
void SetDataFile(
    int series,
    String^ fileFullPath,
    GraphWeaver_DataType type
)

パラメータ

series
型：System..::.Int32
系列番号
fileFullPath
型：System..::.String
フルパス名
type
型：Sakura.GW.AbstractLayer..::.GraphWeaver_DataType
ファイル種別

解説

系列番号を指定し、入力データとしてファイルを使用するよう設定します。
系列番号に使用できる値は、０～SetDataSeriesNoで設定した最大値－１です。

フルパス名にはドライブ名、ファイル名を含む文字列で指定してください。

参照

GraphWeaverData クラス
SetDataFile オーバーロード


SetDataRowData メソッド

[image] [image]

GraphWeaver For Visio ver.1.10
GraphWeaverData..::.SetDataRowData メソッド
GraphWeaverData クラス 参照 フィードバックの送信

オーバーロードの一覧

名前 | 説明
SetDataRowData(List<(Of <(Point>)>)) | 入力Rowデータ設定
SetDataRowData(Int32, List<(Of <(Point>)>)) | 入力Rowデータ設定

参照

GraphWeaverData クラス
GraphWeaverData メンバ


SetDataRowData メソッド (List(Point))

[image]

GraphWeaver For Visio ver.1.10
GraphWeaverData..::.SetDataRowData メソッド (List<(Of <(Point>)>))
GraphWeaverData クラス 参照 フィードバックの送信
入力Rowデータ設定

名前空間 Sakura.GW.AbstractLayer
アセンブリ： Sakura.GW.AbstractLayer (Sakura.GW.AbstractLayer.dll 内)
バージョン: 1.1.0.0 (1.1.0.0)

構文

C#
public void SetDataRowData(
    List<Point> pointList
)
Visual Basic (宣言)
Public Sub SetDataRowData ( _
    pointList As List(Of Point) _
)
Visual C++
public:
void SetDataRowData(
    List<Point>^ pointList
)

パラメータ

pointList
型：System.Collections.Generic..::.List <(Of <( Point >)>)
ポイントリスト

解説

系列番号０の入力データを直接設定します。

参照

GraphWeaverData クラス
SetDataRowData オーバーロード


SetDataRowData メソッド (Int32, List(Point))

[image]

GraphWeaver For Visio ver.1.10
GraphWeaverData..::.SetDataRowData メソッド (Int32, List<(Of <(Point>)>))
GraphWeaverData クラス 参照 フィードバックの送信
入力Rowデータ設定

名前空間 Sakura.GW.AbstractLayer
アセンブリ： Sakura.GW.AbstractLayer (Sakura.GW.AbstractLayer.dll 内)
バージョン: 1.1.0.0 (1.1.0.0)

構文

C#
public bool SetDataRowData(
    int series,
    List<Point> pointList
)
Visual Basic (宣言)
Public Function SetDataRowData ( _
    series As Integer, _
    pointList As List(Of Point) _
) As Boolean
Visual C++
public:
bool SetDataRowData(
    int series,
    List<Point>^ pointList
)

パラメータ

series
型：System..::.Int32
系列数
pointList
型：System.Collections.Generic..::.List <(Of <( Point >)>)
ポイントリスト

戻り値

型：Boolean
設定に成功した場合はtrue。失敗した場合はfalse。

解説

系列番号を指定して入力データを直接設定します。
系列番号に使用できる値は、０～SetDataSeriesNoで設定した最大値－１です。

参照

GraphWeaverData クラス
SetDataRowData オーバーロード


SetDataSeriesNo メソッド

[image]

GraphWeaver For Visio ver.1.10
GraphWeaverData..::.SetDataSeriesNo メソッド
GraphWeaverData クラス 参照 フィードバックの送信
入力データの系列最大番号設定

名前空間 Sakura.GW.AbstractLayer
アセンブリ： Sakura.GW.AbstractLayer (Sakura.GW.AbstractLayer.dll 内)
バージョン: 1.1.0.0 (1.1.0.0)

構文

C#
public bool SetDataSeriesNo(
    int seriesNo
)
Visual Basic (宣言)
Public Function SetDataSeriesNo ( _
    seriesNo As Integer _
) As Boolean
Visual C++
public:
bool SetDataSeriesNo(
    int seriesNo
)

パラメータ

seriesNo
型：System..::.Int32
系列最大番号(1以上)

戻り値

型：Boolean
設定に成功した場合はtrue。失敗した場合はfalse。

解説

DataInfo設定のセット数を設定します。この設定を行うとデータ情報が初期化されるので、設定の前に実行してください。
なお、最大値は９です。

参照

GraphWeaverData クラス


SetDisableGraphBat メソッド

[image]

GraphWeaver For Visio ver.1.10
GraphWeaverData..::.SetDisableGraphBat メソッド
GraphWeaverData クラス 参照 フィードバックの送信
棒無効設定

名前空間 Sakura.GW.AbstractLayer
アセンブリ： Sakura.GW.AbstractLayer (Sakura.GW.AbstractLayer.dll 内)
バージョン: 1.1.0.0 (1.1.0.0)

構文

C#
public void SetDisableGraphBat(
    int seriesNo
)
Visual Basic (宣言)
Public Sub SetDisableGraphBat ( _
    seriesNo As Integer _
)
Visual C++
public:
void SetDisableGraphBat(
    int seriesNo
)

パラメータ

seriesNo
型：System..::.Int32
系列番号(0～)

解説

未実装のため使用できません。

参照

GraphWeaverData クラス


SetDisableGraphPoint メソッド

[image]

GraphWeaver For Visio ver.1.10
GraphWeaverData..::.SetDisableGraphPoint メソッド
GraphWeaverData クラス 参照 フィードバックの送信
点無効設定

名前空間 Sakura.GW.AbstractLayer
アセンブリ： Sakura.GW.AbstractLayer (Sakura.GW.AbstractLayer.dll 内)
バージョン: 1.1.0.0 (1.1.0.0)

構文

C#
public void SetDisableGraphPoint(
    int seriesNo
)
Visual Basic (宣言)
Public Sub SetDisableGraphPoint ( _
    seriesNo As Integer _
)
Visual C++
public:
void SetDisableGraphPoint(
    int seriesNo
)

パラメータ

seriesNo
型：System..::.Int32
系列番号(0～)

解説

未実装のため使用できません。

参照

GraphWeaverData クラス


SetDocumentFile メソッド

[image]

GraphWeaver For Visio ver.1.10
GraphWeaverData..::.SetDocumentFile メソッド
GraphWeaverData クラス 参照 フィードバックの送信
出力ドキュメント設定

名前空間 Sakura.GW.AbstractLayer
アセンブリ： Sakura.GW.AbstractLayer (Sakura.GW.AbstractLayer.dll 内)
バージョン: 1.1.0.0 (1.1.0.0)

構文

C#
public void SetDocumentFile(
    string documentName,
    string fileFullPath,
    string templateFileFullPath
)
Visual Basic (宣言)
Public Sub SetDocumentFile ( _
    documentName As String, _
    fileFullPath As String, _
    templateFileFullPath As String _
)
Visual C++
public:
void SetDocumentFile(
    String^ documentName,
    String^ fileFullPath,
    String^ templateFileFullPath
)

パラメータ

documentName
型：System..::.String
ドキュメント名
fileFullPath
型：System..::.String
ファイルフルパス
templateFileFullPath
型：System..::.String
テンプレートファイルフルパス

解説

出力するドキュメントを設定します。

ドキュメント名は、既存ファイルを指定するときのみ指定し、新規の場合は空欄にしてください。 ファイルフルパスは、既存ファイルを指定するときのみ指定し、新規の場合は空欄にしてください。 テンプレートファイルフルパスは、新規でテンプレートとして使用するファイルがある時のみ指定し、それ以外の場合は空欄にしてください。

参照

GraphWeaverData クラス


SetGraphAxis メソッド

[image]

GraphWeaver For Visio ver.1.10
GraphWeaverData..::.SetGraphAxis メソッド
GraphWeaverData クラス 参照 フィードバックの送信
軸一般設定

名前空間 Sakura.GW.AbstractLayer
アセンブリ： Sakura.GW.AbstractLayer (Sakura.GW.AbstractLayer.dll 内)
バージョン: 1.1.0.0 (1.1.0.0)

構文

C#
public void SetGraphAxis(
    AxisSpec axisSpec,
    bool bEnable,
    double min,
    double max,
    double tics,
    int mTics,
    double tickness,
    RGB axisColor
)
Visual Basic (宣言)
Public Sub SetGraphAxis ( _
    axisSpec As AxisSpec, _
    bEnable As Boolean, _
    min As Double, _
    max As Double, _
    tics As Double, _
    mTics As Integer, _
    tickness As Double, _
    axisColor As RGB _
)
Visual C++
public:
void SetGraphAxis(
    AxisSpec axisSpec,
    bool bEnable,
    double min,
    double max,
    double tics,
    int mTics,
    double tickness,
    RGB^ axisColor
)

パラメータ

axisSpec
型：Sakura.GW.AbstractLayer..::.AxisSpec
軸種別
bEnable
型：System..::.Boolean
有効フラグ
min
型：System..::.Double
最小値
max
型：System..::.Double
最大値
tics
型：System..::.Double
補助線きざみ値
mTics
型：System..::.Int32
第2補助線分割数
tickness
型：System..::.Double
軸太さ
axisColor
型：Sakura.GW.AbstractLayer..::.RGB
軸色

解説

軸の一般属性を設定します。

参照

GraphWeaverData クラス


SetGraphAxisDetail メソッド

[image]

GraphWeaver For Visio ver.1.10
GraphWeaverData..::.SetGraphAxisDetail メソッド
GraphWeaverData クラス 参照 フィードバックの送信
軸詳細設定

名前空間 Sakura.GW.AbstractLayer
アセンブリ： Sakura.GW.AbstractLayer (Sakura.GW.AbstractLayer.dll 内)
バージョン: 1.1.0.0 (1.1.0.0)

構文

C#
public void SetGraphAxisDetail(
    AxisSpec axisSpec,
    string title,
    double fontSize,
    RGB fontColor,
    double ticLength,
    double ticThickness,
    RGB ticColor,
    double ticFontSize,
    RGB ticFontColor,
    double mTicLength,
    double mTicThickness,
    RGB mTicColor
)
Visual Basic (宣言)
Public Sub SetGraphAxisDetail ( _
    axisSpec As AxisSpec, _
    title As String, _
    fontSize As Double, _
    fontColor As RGB, _
    ticLength As Double, _
    ticThickness As Double, _
    ticColor As RGB, _
    ticFontSize As Double, _
    ticFontColor As RGB, _
    mTicLength As Double, _
    mTicThickness As Double, _
    mTicColor As RGB _
)
Visual C++
public:
void SetGraphAxisDetail(
    AxisSpec axisSpec,
    String^ title,
    double fontSize,
    RGB^ fontColor,
    double ticLength,
    double ticThickness,
    RGB^ ticColor,
    double ticFontSize,
    RGB^ ticFontColor,
    double mTicLength,
    double mTicThickness,
    RGB^ mTicColor
)

パラメータ

axisSpec
型：Sakura.GW.AbstractLayer..::.AxisSpec
軸種別
title
型：System..::.String
タイトル
fontSize
型：System..::.Double
タイトルフォントサイズ
fontColor
型：Sakura.GW.AbstractLayer..::.RGB
タイトルフォント色
ticLength
型：System..::.Double
補助線長さ
ticThickness
型：System..::.Double
補助全太さ
ticColor
型：Sakura.GW.AbstractLayer..::.RGB
補助線色
ticFontSize
型：System..::.Double
補助線数値フォントサイズ
ticFontColor
型：Sakura.GW.AbstractLayer..::.RGB
補助線数値フォント色
mTicLength
型：System..::.Double
第2補助線長さ
mTicThickness
型：System..::.Double
第2補助線太さ
mTicColor
型：Sakura.GW.AbstractLayer..::.RGB
第2補助線色

解説

軸の詳細属性を設定します。

参照

GraphWeaverData クラス


SetGraphAxisPack メソッド

[image]

GraphWeaver For Visio ver.1.10
GraphWeaverData..::.SetGraphAxisPack メソッド
GraphWeaverData クラス 参照 フィードバックの送信
軸一括設定

名前空間 Sakura.GW.AbstractLayer
アセンブリ： Sakura.GW.AbstractLayer (Sakura.GW.AbstractLayer.dll 内)
バージョン: 1.1.0.0 (1.1.0.0)

構文

C#
public void SetGraphAxisPack(
    GraphWeaver_AxisPack pack
)
Visual Basic (宣言)
Public Sub SetGraphAxisPack ( _
    pack As GraphWeaver_AxisPack _
)
Visual C++
public:
void SetGraphAxisPack(
    GraphWeaver_AxisPack^ pack
)

パラメータ

pack
型：Sakura.GW.AbstractLayer..::.GraphWeaver_AxisPack
軸情報

解説

軸に関する属性を一括設定します。軸情報設定クラスに各属性値を設定し、このメソッドをコールしてください。

参照

GraphWeaverData クラス


SetGraphBar メソッド

[image] [image]

GraphWeaver For Visio ver.1.10
GraphWeaverData..::.SetGraphBar メソッド
GraphWeaverData クラス 参照 フィードバックの送信

オーバーロードの一覧

名前 | 説明
SetGraphBar(Int32, GraphWeaver_BarPack) | 棒設定
SetGraphBar(BarStyle, BarType, RGB, Double) | 棒設定
SetGraphBar(Int32, BarStyle, BarType, RGB, Double) | 棒設定

参照

GraphWeaverData クラス
GraphWeaverData メンバ


SetGraphBar メソッド (Int32, GraphWeaver_BarPack)

[image]

GraphWeaver For Visio ver.1.10
GraphWeaverData..::.SetGraphBar メソッド (Int32, GraphWeaver_BarPack)
GraphWeaverData クラス 参照 フィードバックの送信
棒設定

名前空間 Sakura.GW.AbstractLayer
アセンブリ： Sakura.GW.AbstractLayer (Sakura.GW.AbstractLayer.dll 内)
バージョン: 1.1.0.0 (1.1.0.0)

構文

C#
public void SetGraphBar(
    int seriesNo,
    GraphWeaver_BarPack pack
)
Visual Basic (宣言)
Public Sub SetGraphBar ( _
    seriesNo As Integer, _
    pack As GraphWeaver_BarPack _
)
Visual C++
public:
void SetGraphBar(
    int seriesNo,
    GraphWeaver_BarPack^ pack
)

パラメータ

seriesNo
型：System..::.Int32
系列番号
pack
型：Sakura.GW.AbstractLayer..::.GraphWeaver_BarPack
棒情報設定

解説

系列番号を指定し、棒情報設定クラスに設定した属性値により設定します。 系列番号に使用できる値は、０～SetDataSeriesNoで設定した最大値－１です。

参照

GraphWeaverData クラス
SetGraphBar オーバーロード


SetGraphBar メソッド (BarStyle, BarType, RGB, Double)

[image]

GraphWeaver For Visio ver.1.10
GraphWeaverData..::.SetGraphBar メソッド (BarStyle, BarType, RGB, Double)
GraphWeaverData クラス 参照 フィードバックの送信
棒設定

名前空間 Sakura.GW.AbstractLayer
アセンブリ： Sakura.GW.AbstractLayer (Sakura.GW.AbstractLayer.dll 内)
バージョン: 1.1.0.0 (1.1.0.0)

構文

C#
public void SetGraphBar(
    BarStyle style,
    BarType barType,
    RGB barColor,
    double width
)
Visual Basic (宣言)
Public Sub SetGraphBar ( _
    style As BarStyle, _
    barType As BarType, _
    barColor As RGB, _
    width As Double _
)
Visual C++
public:
void SetGraphBar(
    BarStyle style,
    BarType barType,
    RGB^ barColor,
    double width
)

パラメータ

style
型：Sakura.GW.AbstractLayer..::.BarStyle
形状
barType
型：Sakura.GW.AbstractLayer..::.BarType
表示タイプ
barColor
型：Sakura.GW.AbstractLayer..::.RGB
色
width
型：System..::.Double
幅

解説

系列番号０の棒属性を設定します。

参照

GraphWeaverData クラス
SetGraphBar オーバーロード


SetGraphBar メソッド (Int32, BarStyle, BarType, RGB, Double)

[image]

GraphWeaver For Visio ver.1.10
GraphWeaverData..::.SetGraphBar メソッド (Int32, BarStyle, BarType, RGB, Double)
GraphWeaverData クラス 参照 フィードバックの送信
棒設定

名前空間 Sakura.GW.AbstractLayer
アセンブリ： Sakura.GW.AbstractLayer (Sakura.GW.AbstractLayer.dll 内)
バージョン: 1.1.0.0 (1.1.0.0)

構文

C#
public void SetGraphBar(
    int seriesNo,
    BarStyle style,
    BarType barType,
    RGB barColor,
    double width
)
Visual Basic (宣言)
Public Sub SetGraphBar ( _
    seriesNo As Integer, _
    style As BarStyle, _
    barType As BarType, _
    barColor As RGB, _
    width As Double _
)
Visual C++
public:
void SetGraphBar(
    int seriesNo,
    BarStyle style,
    BarType barType,
    RGB^ barColor,
    double width
)

パラメータ

seriesNo
型：System..::.Int32
系列番号(0～)
style
型：Sakura.GW.AbstractLayer..::.BarStyle
形状
barType
型：Sakura.GW.AbstractLayer..::.BarType
表示タイプ
barColor
型：Sakura.GW.AbstractLayer..::.RGB
色
width
型：System..::.Double
幅

解説

系列番号を指定し棒属性を設定します。 系列番号に使用できる値は、０～SetDataSeriesNoで設定した最大値－１です。

参照

GraphWeaverData クラス
SetGraphBar オーバーロード


SetGraphImageLimit メソッド

[image]

GraphWeaver For Visio ver.1.10
GraphWeaverData..::.SetGraphImageLimit メソッド
GraphWeaverData クラス 参照 フィードバックの送信
描画象限設定

名前空間 Sakura.GW.AbstractLayer
アセンブリ： Sakura.GW.AbstractLayer (Sakura.GW.AbstractLayer.dll 内)
バージョン: 1.1.0.0 (1.1.0.0)

構文

C#
public void SetGraphImageLimit(
    Quadrant quadrant
)
Visual Basic (宣言)
Public Sub SetGraphImageLimit ( _
    quadrant As Quadrant _
)
Visual C++
public:
void SetGraphImageLimit(
    Quadrant quadrant
)

パラメータ

quadrant
型：Sakura.GW.AbstractLayer..::.Quadrant
描画対象象限

解説

描画するグラフの象限を設定します。グラフ種別によって使用できる象限の種類が限定されているので注意してください。

参照

GraphWeaverData クラス
Sakura.GW.AbstractLayer..::.Quadrant


SetGraphPoint メソッド

[image] [image]

GraphWeaver For Visio ver.1.10
GraphWeaverData..::.SetGraphPoint メソッド
GraphWeaverData クラス 参照 フィードバックの送信

オーバーロードの一覧

名前 | 説明
SetGraphPoint(Int32, GraphWeaver_PointPack) | 点設定
SetGraphPoint(PointStyle, RGB, Double, Boolean, RGB, Double) | 点設定
SetGraphPoint(Int32, PointStyle, RGB, Double, Boolean, RGB, Double) | 点設定

参照

GraphWeaverData クラス
GraphWeaverData メンバ


SetGraphPoint メソッド (Int32, GraphWeaver_PointPack)

[image]

GraphWeaver For Visio ver.1.10
GraphWeaverData..::.SetGraphPoint メソッド (Int32, GraphWeaver_PointPack)
GraphWeaverData クラス 参照 フィードバックの送信
点設定

名前空間 Sakura.GW.AbstractLayer
アセンブリ： Sakura.GW.AbstractLayer (Sakura.GW.AbstractLayer.dll 内)
バージョン: 1.1.0.0 (1.1.0.0)

構文

C#
public void SetGraphPoint(
    int seriesNo,
    GraphWeaver_PointPack pack
)
Visual Basic (宣言)
Public Sub SetGraphPoint ( _
    seriesNo As Integer, _
    pack As GraphWeaver_PointPack _
)
Visual C++
public:
void SetGraphPoint(
    int seriesNo,
    GraphWeaver_PointPack^ pack
)

パラメータ

seriesNo
型：System..::.Int32
系列番号（0～）
pack
型：Sakura.GW.AbstractLayer..::.GraphWeaver_PointPack
点情報設定

解説

系列番号を指定し、点情報設定クラスに設定した属性値により設定します。 系列番号に使用できる値は、０～SetDataSeriesNoで設定した最大値－１です。

参照

GraphWeaverData クラス
SetGraphPoint オーバーロード


SetGraphPoint メソッド (PointStyle, RGB, Double, Boolean, RGB, Double)

[image]

GraphWeaver For Visio ver.1.10
GraphWeaverData..::.SetGraphPoint メソッド (PointStyle, RGB, Double, Boolean, RGB, Double)
GraphWeaverData クラス 参照 フィードバックの送信
点設定

名前空間 Sakura.GW.AbstractLayer
アセンブリ： Sakura.GW.AbstractLayer (Sakura.GW.AbstractLayer.dll 内)
バージョン: 1.1.0.0 (1.1.0.0)

構文

C#
public void SetGraphPoint(
    PointStyle style,
    RGB pointColor,
    double size,
    bool bConnect,
    RGB lineColor,
    double lineThickness
)
Visual Basic (宣言)
Public Sub SetGraphPoint ( _
    style As PointStyle, _
    pointColor As RGB, _
    size As Double, _
    bConnect As Boolean, _
    lineColor As RGB, _
    lineThickness As Double _
)
Visual C++
public:
void SetGraphPoint(
    PointStyle style,
    RGB^ pointColor,
    double size,
    bool bConnect,
    RGB^ lineColor,
    double lineThickness
)

パラメータ

style
型：Sakura.GW.AbstractLayer..::.PointStyle
形状
pointColor
型：Sakura.GW.AbstractLayer..::.RGB
色
size
型：System..::.Double
サイズ
bConnect
型：System..::.Boolean
点の線接続するか？
lineColor
型：Sakura.GW.AbstractLayer..::.RGB
線色
lineThickness
型：System..::.Double
線太さ

解説

系列番号０の点属性を設定します。

参照

GraphWeaverData クラス
SetGraphPoint オーバーロード


SetGraphPoint メソッド (Int32, PointStyle, RGB, Double, Boolean, RGB, Double)

[image]

GraphWeaver For Visio ver.1.10
GraphWeaverData..::.SetGraphPoint メソッド (Int32, PointStyle, RGB, Double, Boolean, RGB, Double)
GraphWeaverData クラス 参照 フィードバックの送信
点設定

名前空間 Sakura.GW.AbstractLayer
アセンブリ： Sakura.GW.AbstractLayer (Sakura.GW.AbstractLayer.dll 内)
バージョン: 1.1.0.0 (1.1.0.0)

構文

C#
public void SetGraphPoint(
    int seriesNo,
    PointStyle style,
    RGB pointColor,
    double size,
    bool bConnect,
    RGB lineColor,
    double lineThickness
)
Visual Basic (宣言)
Public Sub SetGraphPoint ( _
    seriesNo As Integer, _
    style As PointStyle, _
    pointColor As RGB, _
    size As Double, _
    bConnect As Boolean, _
    lineColor As RGB, _
    lineThickness As Double _
)
Visual C++
public:
void SetGraphPoint(
    int seriesNo,
    PointStyle style,
    RGB^ pointColor,
    double size,
    bool bConnect,
    RGB^ lineColor,
    double lineThickness
)

パラメータ

seriesNo
型：System..::.Int32
系列番号(0～)
style
型：Sakura.GW.AbstractLayer..::.PointStyle
形状
pointColor
型：Sakura.GW.AbstractLayer..::.RGB
色
size
型：System..::.Double
サイズ
bConnect
型：System..::.Boolean
点の線接続するか？
lineColor
型：Sakura.GW.AbstractLayer..::.RGB
線色
lineThickness
型：System..::.Double
線太さ

解説

系列番号を指定し点属性を設定します。 系列番号に使用できる値は、０～SetDataSeriesNoで設定した最大値－１です。

参照

GraphWeaverData クラス
SetGraphPoint オーバーロード


SetGraphSize メソッド

[image]

GraphWeaver For Visio ver.1.10
GraphWeaverData..::.SetGraphSize メソッド
GraphWeaverData クラス 参照 フィードバックの送信
グラフ情報設定

名前空間 Sakura.GW.AbstractLayer
アセンブリ： Sakura.GW.AbstractLayer (Sakura.GW.AbstractLayer.dll 内)
バージョン: 1.1.0.0 (1.1.0.0)

構文

C#
public void SetGraphSize(
    GraphType graphType,
    double width,
    double height,
    double widthOffset,
    double heightOffset
)
Visual Basic (宣言)
Public Sub SetGraphSize ( _
    graphType As GraphType, _
    width As Double, _
    height As Double, _
    widthOffset As Double, _
    heightOffset As Double _
)
Visual C++
public:
void SetGraphSize(
    GraphType graphType,
    double width,
    double height,
    double widthOffset,
    double heightOffset
)

パラメータ

graphType
型：Sakura.GW.AbstractLayer..::.GraphType
グラフ種別
width
型：System..::.Double
幅
height
型：System..::.Double
高さ
widthOffset
型：System..::.Double
ページに対する横オフセット
heightOffset
型：System..::.Double
ページに対する縦オフセット

解説

グラフの一般属性を設定します。

参照

GraphWeaverData クラス


SetGraphTitle メソッド

[image]

GraphWeaver For Visio ver.1.10
GraphWeaverData..::.SetGraphTitle メソッド
GraphWeaverData クラス 参照 フィードバックの送信
グラフタイトル設定

名前空間 Sakura.GW.AbstractLayer
アセンブリ： Sakura.GW.AbstractLayer (Sakura.GW.AbstractLayer.dll 内)
バージョン: 1.1.0.0 (1.1.0.0)

構文

C#
public void SetGraphTitle(
    string graphTitle,
    GraphWeaver_FontAttribute fontAttr
)
Visual Basic (宣言)
Public Sub SetGraphTitle ( _
    graphTitle As String, _
    fontAttr As GraphWeaver_FontAttribute _
)
Visual C++
public:
void SetGraphTitle(
    String^ graphTitle,
    GraphWeaver_FontAttribute^ fontAttr
)

パラメータ

graphTitle
型：System..::.String
グラフタイトル
fontAttr
型：Sakura.GW.AbstractLayer..::.GraphWeaver_FontAttribute
フォント属性

解説

描画するグラフのタイトルとして表示する文字列の属性を設定します。
描画したくない場合は、グラフタイトルに空欄を指定してください。

参照

GraphWeaverData クラス


SetPage メソッド

[image]

GraphWeaver For Visio ver.1.10
GraphWeaverData..::.SetPage メソッド
GraphWeaverData クラス 参照 フィードバックの送信
ページ情報設定

名前空間 Sakura.GW.AbstractLayer
アセンブリ： Sakura.GW.AbstractLayer (Sakura.GW.AbstractLayer.dll 内)
バージョン: 1.1.0.0 (1.1.0.0)

構文

C#
public void SetPage(
    string pageName,
    double width,
    double height,
    double scaling,
    LengthUnit unit
)
Visual Basic (宣言)
Public Sub SetPage ( _
    pageName As String, _
    width As Double, _
    height As Double, _
    scaling As Double, _
    unit As LengthUnit _
)
Visual C++
public:
void SetPage(
    String^ pageName,
    double width,
    double height,
    double scaling,
    LengthUnit unit
)

パラメータ

pageName
型：System..::.String
ページ名
width
型：System..::.Double
幅
height
型：System..::.Double
高さ
scaling
型：System..::.Double
スケール係数
unit
型：Sakura.GW.AbstractLayer..::.LengthUnit
単位

解説

ページの各種属性を設定できます。ページ名は必須なので空欄にしないでください。
通常、スケール係数は1.0を指定してください。

参照

GraphWeaverData クラス


GraphWeaverData.CommandID 列挙体

[image]

GraphWeaver For Visio ver.1.10
GraphWeaverData..::.CommandID 列挙体
GraphWeaverData クラス 参照 フィードバックの送信
コマンドID

名前空間 Sakura.GW.AbstractLayer
アセンブリ： Sakura.GW.AbstractLayer (Sakura.GW.AbstractLayer.dll 内)
バージョン: 1.1.0.0 (1.1.0.0)

構文

C#
public enum CommandID
Visual Basic (宣言)
Public Enumeration CommandID
Visual C++
public enum class CommandID

メンバ

メンバ名 | 説明
None | 未定義
Abort | 処理中断
loadData | 元データ読み込み
saveData | 元データへ書き込み
eraseData | データ削除
setupGraph | グラフ書式設定
storeGraph | グラフ書式へ保存
resetupGraph | グラフ書式再設定
drawGraphAll | グラフ一括描画
drawGraph | グラフ描画
redrawGraph | グラフ再描画
deleteGraph | グラフ削除
reflectGraph | 表示グラフからの反映
drawPoint | データ点のみ描画
deletePoint | データ点のみ削除
redrawGraphPoint | データのみ再計算描画

解説

実行する内容を示す列挙体です。 GraphWeaverData.SetCommandメソッドで設定する値として使用します。
CommandID | 詳細説明
None | 未定義 （使用不可）
Abort | 処理中断 ・実行中のコマンド処理を中断します
loadData | 元データ読み込み ・SetDataFileで設定されたファイルからデータを読み込みます
saveData | 元データへ書き込み (未対応)
eraseData | データ削除 ・SetDataFileで設定されたファイルを削除します
setupGraph | グラフ書式設定 ・読み込んだデータとグラフ設定を元にグラフ座標計算を行います ・loadDataコマンド実行済みの必要があります（SetDataFileで設定した系列データの場合） ・設定したデータとグラフ設定を元にグラフ座標計算を行います（SetDataRawDataで設定した系列データの場合）
storeGraph | グラフ書式への保存 (未対応)
resetupGraph | グラフ書式再設定 ・描画済みグラフに対し、現在保持しているデータを元に再計算を行います
drawGraphAll | グラフ一括描画 (loadData+setupGraph+drawGraph) ・グラフを描画するために必要なコマンドを一括で実行します
drawGraph | グラフ描画 ・グラフ座標計算済みのグラフを描画します（setupGraph済みの必要があります）
redrawGraph | グラフ再描画 ・グラフ描画済みのページに対して、一度グラフを消去し再描画します ・deleteGraph + drawGraphと同じです
deleteGraph | グラフ削除 ・描画されたグラフを消去します（軸、点等がページから消去されます）
reflectGraph | 表示グラフからの反映 (未対応)
drawPoint | データ点のみ描画 ・ページに対して、データ点およびそれに付随する要素の描画を行います
deletePoint | データ点のみ削除 ・描画済みページからデータ点およびそれに付随する要素の削除を行います
redrawGraphPoint | データ点のみ再計算描画 ・描画済みページからデータ点およびそれに付随する要素の削除を行い、再描画します ・deletePoint+drawPointと同じです

参照


LengthUnit 列挙体

[image]

GraphWeaver For Visio ver.1.10
LengthUnit 列挙体
参照 フィードバックの送信
長さ単位種別

名前空間 Sakura.GW.AbstractLayer
アセンブリ： Sakura.GW.AbstractLayer (Sakura.GW.AbstractLayer.dll 内)
バージョン: 1.1.0.0 (1.1.0.0)

構文

C#
public enum LengthUnit
Visual Basic (宣言)
Public Enumeration LengthUnit
Visual C++
public enum class LengthUnit

メンバ

メンバ名 | 説明
mm | ミリ単位
inch | インチ単位

解説

長さの単位を示す列挙体です。GraphWeaverData.SetPageで設定します。

グラフ内では全共通の単位として使用されます。

参照

Sakura.GW.AbstractLayer 名前空間
GraphWeaverData..::.SetPage(String, Double, Double, Double, LengthUnit)


PointStyle 列挙体

[image]

GraphWeaver For Visio ver.1.10
PointStyle 列挙体
参照 フィードバックの送信
点形状

名前空間 Sakura.GW.AbstractLayer
アセンブリ： Sakura.GW.AbstractLayer (Sakura.GW.AbstractLayer.dll 内)
バージョン: 1.1.0.0 (1.1.0.0)

構文

C#
public enum PointStyle
Visual Basic (宣言)
Public Enumeration PointStyle
Visual C++
public enum class PointStyle

メンバ

メンバ名 | 説明
None | 未定義
Circle | 円
Triangle | 三角
Square | 四角
Pentagon | 五画
Hexagon | 六角
Heptagon | 七角
Octagon | 八角
Star | 星
Cross | 十字

解説

グラフ形状が以下のグラフの時、データを表す点の形状種別を示す列挙体です。
  • LineChart

参照

Sakura.GW.AbstractLayer..::.GraphWeaver_PointPack


Quadrant 列挙体

[image]

GraphWeaver For Visio ver.1.10
Quadrant 列挙体
参照 フィードバックの送信
象限種別

名前空間 Sakura.GW.AbstractLayer
アセンブリ： Sakura.GW.AbstractLayer (Sakura.GW.AbstractLayer.dll 内)
バージョン: 1.1.0.0 (1.1.0.0)

構文

C#
public enum Quadrant
Visual Basic (宣言)
Public Enumeration Quadrant
Visual C++
public enum class Quadrant

メンバ

メンバ名 | 説明
QuadrantAll | 全象限
Quadrant1 | 第一象限
Quadrant2 | 第二象限
Quadrant3 | 第三象限
Quadrant4 | 第四象限
Quadrant12 | 第一・二象限
Quadrant23 | 第二・三象限
Quadrant34 | 第三・四象限
Quadrant14 | 第一・四象限

解説

対象とする象限の種別を表す列挙体です。

グラフ種別により使用可能な象限が異なるので注意してください。

グラフ種別(GraphType) | 使用可能象限
LineChart | 全て
BarChart | QuadrantAllのみ

参照


RGB クラス

[image]

GraphWeaver For Visio ver.1.10
RGB クラス
メンバ 使用例 参照 フィードバックの送信
RGB色クラス

名前空間 Sakura.GW.AbstractLayer
アセンブリ： Sakura.GW.AbstractLayer (Sakura.GW.AbstractLayer.dll 内)
バージョン: 1.1.0.0 (1.1.0.0)

構文

C#
public class RGB
Visual Basic (宣言)
Public Class RGB
Visual C++
public ref class RGB

解説

GraphWeaverで色を指定するためのクラスです。

コンストラクタにSakura.GW.AbstractLayer.ColorIndexを指定してインスタンス化します。

インスタンス後は、setIndex, setRGBメソッドを指定して色を指定できます。

使用例

CopyC#
RGB rgbRed = new RGB(ColorIndex.Red);

RGB rgbBlue = new RGB();
rgbBlue.setIndex(ColorIndex.Blue);
rgbBlue.setRGB(0,0,255);

継承階層

System..::.Object
Sakura.GW.AbstractLayer..::.RGB

参照

RGB メンバ
色インデックス


RGB メンバ

[image] [image]

GraphWeaver For Visio ver.1.10
RGB メンバ
RGB クラス コンストラクタ メソッド フィールド 参照 フィードバックの送信

RGB 型で公開されるメンバを以下の表に示します。

コンストラクタ

名前 | 説明
RGB | オーバーロードされます。

メソッド

名前 | 説明
IsTranslate | オーバーロードされます。
setIndex | 色指定(ColorIndex)
setRGB | 色指定(RGB)
ToLong | オーバーロードされます。
ToString | オーバーロードされます。

フィールド

名前 | 説明
Blue | 青数値(0～255)
Green | 緑数値(0～255)
Red | 赤数値(0～255)

参照

RGB クラス


RGB コンストラクタ

[image] [image]

GraphWeaver For Visio ver.1.10
RGB コンストラクタ
RGB クラス 参照 フィードバックの送信

オーバーロードの一覧

名前 | 説明
RGB()()() | 引数なしコンストラクタ
RGB(ColorIndex) | コンストラクタ（色インデックス指定）
RGB(Int64) | コンストラクタ（long値指定）
RGB(Byte, Byte, Byte) | コンストラクタ（RGB値指定）

参照

RGB クラス
RGB メンバ


RGB コンストラクタ

[image]

GraphWeaver For Visio ver.1.10
RGB コンストラクタ
RGB クラス 参照 フィードバックの送信
引数なしコンストラクタ

名前空間 Sakura.GW.AbstractLayer
アセンブリ： Sakura.GW.AbstractLayer (Sakura.GW.AbstractLayer.dll 内)
バージョン: 1.1.0.0 (1.1.0.0)

構文

C#
public RGB()
Visual Basic (宣言)
Public Sub New
Visual C++
public:
RGB()

参照

RGB クラス
RGB オーバーロード


RGB コンストラクタ (ColorIndex)

[image]

GraphWeaver For Visio ver.1.10
RGB コンストラクタ (ColorIndex)
RGB クラス 参照 フィードバックの送信
コンストラクタ（色インデックス指定）

名前空間 Sakura.GW.AbstractLayer
アセンブリ： Sakura.GW.AbstractLayer (Sakura.GW.AbstractLayer.dll 内)
バージョン: 1.1.0.0 (1.1.0.0)

構文

C#
public RGB(
    ColorIndex index
)
Visual Basic (宣言)
Public Sub New ( _
    index As ColorIndex _
)
Visual C++
public:
RGB(
    ColorIndex index
)

パラメータ

index
型：Sakura.GW.AbstractLayer..::.ColorIndex
色インデックス

参照

RGB クラス
RGB オーバーロード


RGB コンストラクタ (Int64)

[image]

GraphWeaver For Visio ver.1.10
RGB コンストラクタ (Int64)
RGB クラス 参照 フィードバックの送信
コンストラクタ（long値指定）

名前空間 Sakura.GW.AbstractLayer
アセンブリ： Sakura.GW.AbstractLayer (Sakura.GW.AbstractLayer.dll 内)
バージョン: 1.1.0.0 (1.1.0.0)

構文

C#
public RGB(
    long data
)
Visual Basic (宣言)
Public Sub New ( _
    data As Long _
)
Visual C++
public:
RGB(
    long long data
)

パラメータ

data
型：System..::.Int64
longRGB値

解説

これを使用してインスタンスを生成しないでください。

参照

RGB クラス
RGB オーバーロード


RGB コンストラクタ (Byte, Byte, Byte)

[image]

GraphWeaver For Visio ver.1.10
RGB コンストラクタ (Byte, Byte, Byte)
RGB クラス 参照 フィードバックの送信
コンストラクタ（RGB値指定）

名前空間 Sakura.GW.AbstractLayer
アセンブリ： Sakura.GW.AbstractLayer (Sakura.GW.AbstractLayer.dll 内)
バージョン: 1.1.0.0 (1.1.0.0)

構文

C#
public RGB(
    byte red,
    byte green,
    byte blue
)
Visual Basic (宣言)
Public Sub New ( _
    red As Byte, _
    green As Byte, _
    blue As Byte _
)
Visual C++
public:
RGB(
    unsigned char red,
    unsigned char green,
    unsigned char blue
)

パラメータ

red
型：System..::.Byte
赤数値(0～255)
green
型：System..::.Byte
緑数値(0～255)
blue
型：System..::.Byte
青数値(0～255)

参照

RGB クラス
RGB オーバーロード


RGB フィールド

[image] [image]

GraphWeaver For Visio ver.1.10
RGB フィールド
RGB クラス 参照 フィードバックの送信

RGB 型で公開されるメンバを以下の表に示します。

フィールド

名前 | 説明
Blue | 青数値(0～255)
Green | 緑数値(0～255)
Red | 赤数値(0～255)

参照

RGB クラス


Blue フィールド

[image]

GraphWeaver For Visio ver.1.10
RGB..::.Blue フィールド
RGB クラス 参照 フィードバックの送信
青数値(0～255)

名前空間 Sakura.GW.AbstractLayer
アセンブリ： Sakura.GW.AbstractLayer (Sakura.GW.AbstractLayer.dll 内)
バージョン: 1.1.0.0 (1.1.0.0)

構文

C#
public byte Blue
Visual Basic (宣言)
Public Blue As Byte
Visual C++
public:
unsigned char Blue

参照

RGB クラス


Green フィールド

[image]

GraphWeaver For Visio ver.1.10
RGB..::.Green フィールド
RGB クラス 参照 フィードバックの送信
緑数値(0～255)

名前空間 Sakura.GW.AbstractLayer
アセンブリ： Sakura.GW.AbstractLayer (Sakura.GW.AbstractLayer.dll 内)
バージョン: 1.1.0.0 (1.1.0.0)

構文

C#
public byte Green
Visual Basic (宣言)
Public Green As Byte
Visual C++
public:
unsigned char Green

参照

RGB クラス


Red フィールド

[image]

GraphWeaver For Visio ver.1.10
RGB..::.Red フィールド
RGB クラス 参照 フィードバックの送信
赤数値(0～255)

名前空間 Sakura.GW.AbstractLayer
アセンブリ： Sakura.GW.AbstractLayer (Sakura.GW.AbstractLayer.dll 内)
バージョン: 1.1.0.0 (1.1.0.0)

構文

C#
public byte Red
Visual Basic (宣言)
Public Red As Byte
Visual C++
public:
unsigned char Red

参照

RGB クラス


RGB メソッド

[image] [image]

GraphWeaver For Visio ver.1.10
RGB メソッド
RGB クラス 参照 フィードバックの送信

RGB 型で公開されるメンバを以下の表に示します。

メソッド

名前 | 説明
IsTranslate | オーバーロードされます。
setIndex | 色指定(ColorIndex)
setRGB | 色指定(RGB)
ToLong | オーバーロードされます。
ToString | オーバーロードされます。

参照

RGB クラス


IsTranslate メソッド

[image] [image]

GraphWeaver For Visio ver.1.10
RGB..::.IsTranslate メソッド
RGB クラス 参照 フィードバックの送信

オーバーロードの一覧

名前 | 説明
IsTranslate()()() | 透明色判定
IsTranslate(Int64) | 透明色判定

参照

RGB クラス
RGB メンバ


IsTranslate メソッド

[image]

GraphWeaver For Visio ver.1.10
RGB..::.IsTranslate メソッド
RGB クラス 参照 フィードバックの送信
透明色判定

名前空間 Sakura.GW.AbstractLayer
アセンブリ： Sakura.GW.AbstractLayer (Sakura.GW.AbstractLayer.dll 内)
バージョン: 1.1.0.0 (1.1.0.0)

構文

C#
public bool IsTranslate()
Visual Basic (宣言)
Public Function IsTranslate As Boolean
Visual C++
public:
bool IsTranslate()

戻り値

true:透明色, false:非透明色

参照

RGB クラス
IsTranslate オーバーロード


IsTranslate メソッド (Int64)

[image]

GraphWeaver For Visio ver.1.10
RGB..::.IsTranslate メソッド (Int64)
RGB クラス 参照 フィードバックの送信
透明色判定

名前空間 Sakura.GW.AbstractLayer
アセンブリ： Sakura.GW.AbstractLayer (Sakura.GW.AbstractLayer.dll 内)
バージョン: 1.1.0.0 (1.1.0.0)

構文

C#
public static bool IsTranslate(
    long data
)
Visual Basic (宣言)
Public Shared Function IsTranslate ( _
    data As Long _
) As Boolean
Visual C++
public:
static bool IsTranslate(
    long long data
)

パラメータ

data
型：System..::.Int64
RGB値

戻り値

型：Boolean
設定値が透明色ならtrue、それ以外はfalse。

参照

RGB クラス
IsTranslate オーバーロード


setIndex メソッド

[image]

GraphWeaver For Visio ver.1.10
RGB..::.setIndex メソッド
RGB クラス 参照 フィードバックの送信
色指定(ColorIndex)

名前空間 Sakura.GW.AbstractLayer
アセンブリ： Sakura.GW.AbstractLayer (Sakura.GW.AbstractLayer.dll 内)
バージョン: 1.1.0.0 (1.1.0.0)

構文

C#
public void setIndex(
    ColorIndex index
)
Visual Basic (宣言)
Public Sub setIndex ( _
    index As ColorIndex _
)
Visual C++
public:
void setIndex(
    ColorIndex index
)

パラメータ

index
型：Sakura.GW.AbstractLayer..::.ColorIndex
色インデックス

参照

RGB クラス


setRGB メソッド

[image]

GraphWeaver For Visio ver.1.10
RGB..::.setRGB メソッド
RGB クラス 参照 フィードバックの送信
色指定(RGB)

名前空間 Sakura.GW.AbstractLayer
アセンブリ： Sakura.GW.AbstractLayer (Sakura.GW.AbstractLayer.dll 内)
バージョン: 1.1.0.0 (1.1.0.0)

構文

C#
public void setRGB(
    byte red,
    byte green,
    byte blue
)
Visual Basic (宣言)
Public Sub setRGB ( _
    red As Byte, _
    green As Byte, _
    blue As Byte _
)
Visual C++
public:
void setRGB(
    unsigned char red,
    unsigned char green,
    unsigned char blue
)

パラメータ

red
型：System..::.Byte
赤数値(0～255)
green
型：System..::.Byte
緑数値(0～255)
blue
型：System..::.Byte
青数値(0～255)

参照

RGB クラス


ToLong メソッド

[image] [image]

GraphWeaver For Visio ver.1.10
RGB..::.ToLong メソッド
RGB クラス 参照 フィードバックの送信

オーバーロードの一覧

名前 | 説明
ToLong()()() | 数値変換
ToLong(ColorIndex) | 数値変換

参照

RGB クラス
RGB メンバ


ToLong メソッド

[image]

GraphWeaver For Visio ver.1.10
RGB..::.ToLong メソッド
RGB クラス 参照 フィードバックの送信
数値変換

名前空間 Sakura.GW.AbstractLayer
アセンブリ： Sakura.GW.AbstractLayer (Sakura.GW.AbstractLayer.dll 内)
バージョン: 1.1.0.0 (1.1.0.0)

構文

C#
public long ToLong()
Visual Basic (宣言)
Public Function ToLong As Long
Visual C++
public:
long long ToLong()

戻り値

型：Int64
RGB整数値

参照

RGB クラス
ToLong オーバーロード


ToLong メソッド (ColorIndex)

[image]

GraphWeaver For Visio ver.1.10
RGB..::.ToLong メソッド (ColorIndex)
RGB クラス 参照 フィードバックの送信
数値変換

名前空間 Sakura.GW.AbstractLayer
アセンブリ： Sakura.GW.AbstractLayer (Sakura.GW.AbstractLayer.dll 内)
バージョン: 1.1.0.0 (1.1.0.0)

構文

C#
public static long ToLong(
    ColorIndex index
)
Visual Basic (宣言)
Public Shared Function ToLong ( _
    index As ColorIndex _
) As Long
Visual C++
public:
static long long ToLong(
    ColorIndex index
)

パラメータ

index
型：Sakura.GW.AbstractLayer..::.ColorIndex
色インデックス

戻り値

型：Int64
RGB整数値

参照

RGB クラス
ToLong オーバーロード


ToString メソッド

[image] [image]

GraphWeaver For Visio ver.1.10
RGB..::.ToString メソッド
RGB クラス 参照 フィードバックの送信

オーバーロードの一覧

名前 | 説明
ToString()()() | 文字列変換 (Object..::.ToString()()()をオーバーライド)
ToString(ColorIndex) | 文字列変換
ToString(Int64) | 文字列変換

参照

RGB クラス
RGB メンバ


ToString メソッド

[image]

GraphWeaver For Visio ver.1.10
RGB..::.ToString メソッド
RGB クラス 参照 フィードバックの送信
文字列変換

名前空間 Sakura.GW.AbstractLayer
アセンブリ： Sakura.GW.AbstractLayer (Sakura.GW.AbstractLayer.dll 内)
バージョン: 1.1.0.0 (1.1.0.0)

構文

C#
public override string ToString()
Visual Basic (宣言)
Public Overrides Function ToString As String
Visual C++
public:
virtual String^ ToString() override

戻り値

型：String
描画用RGB文字列

参照

RGB クラス
ToString オーバーロード


ToString メソッド (ColorIndex)

[image]

GraphWeaver For Visio ver.1.10
RGB..::.ToString メソッド (ColorIndex)
RGB クラス 参照 フィードバックの送信
文字列変換

名前空間 Sakura.GW.AbstractLayer
アセンブリ： Sakura.GW.AbstractLayer (Sakura.GW.AbstractLayer.dll 内)
バージョン: 1.1.0.0 (1.1.0.0)

構文

C#
public static string ToString(
    ColorIndex index
)
Visual Basic (宣言)
Public Shared Function ToString ( _
    index As ColorIndex _
) As String
Visual C++
public:
static String^ ToString(
    ColorIndex index
)

パラメータ

index
型：Sakura.GW.AbstractLayer..::.ColorIndex

[Missing <param name="index"/> documentation for "M:Sakura.GW.AbstractLayer.RGB.ToString(Sakura.GW.AbstractLayer.ColorIndex)"]

戻り値

型：String
"RGB(r,g,b)"文字列

参照

RGB クラス
ToString オーバーロード


ToString メソッド (Int64)

[image]

GraphWeaver For Visio ver.1.10
RGB..::.ToString メソッド (Int64)
RGB クラス 参照 フィードバックの送信
文字列変換

名前空間 Sakura.GW.AbstractLayer
アセンブリ： Sakura.GW.AbstractLayer (Sakura.GW.AbstractLayer.dll 内)
バージョン: 1.1.0.0 (1.1.0.0)

構文

C#
public static string ToString(
    long rgbColor
)
Visual Basic (宣言)
Public Shared Function ToString ( _
    rgbColor As Long _
) As String
Visual C++
public:
static String^ ToString(
    long long rgbColor
)

パラメータ

rgbColor
型：System..::.Int64
RGB色

戻り値

型：String
"RGB(r,g,b)"文字列

参照

RGB クラス
ToString オーバーロード


Sakura.GW.AbstractLayer.Visio 名前空間

[image]

GraphWeaver For Visio ver.1.10
Sakura.GW.AbstractLayer.Visio 名前空間
フィードバックの送信
GraphWeaver Visio抽象レイヤー

クラス

クラス | 説明
GraphWeaverMng | GraphWeaver管理マネージャ

デリゲート

デリゲート | 説明
GraphWeaverMng..::.callbackResponse | 処理終了時コールバック関数型
GraphWeaverMng..::.callbackVisioClosed | Visio終了検出コールバック関数型


GraphWeaverMng クラス

[image]

GraphWeaver For Visio ver.1.10
GraphWeaverMng クラス
メンバ 参照 フィードバックの送信
GraphWeaver管理マネージャ

名前空間 Sakura.GW.AbstractLayer.Visio
アセンブリ： Sakura.GW.AbstractLayer.Visio (Sakura.GW.AbstractLayer.Visio.dll 内)
バージョン: 1.1.0.0 (1.1.0.0)

構文

C#
public class GraphWeaverMng : CommonLayer
Visual Basic (宣言)
Public Class GraphWeaverMng _
    Inherits CommonLayer
Visual C++
public ref class GraphWeaverMng : public CommonLayer

継承階層

System..::.Object
BaseMng
CommonMng
CommonLayer
Sakura.GW.AbstractLayer.Visio..::.GraphWeaverMng

参照

GraphWeaverMng メンバ
Sakura.GW.AbstractLayer.Visio 名前空間


GraphWeaverMng メンバ

[image] [image]

GraphWeaver For Visio ver.1.10
GraphWeaverMng メンバ
GraphWeaverMng クラス コンストラクタ メソッド フィールド 参照 フィードバックの送信

GraphWeaverMng 型で公開されるメンバを以下の表に示します。

コンストラクタ

名前 | 説明
GraphWeaverMng | オーバーロードされます。

メソッド

名前 | 説明
closeDocument | ドキュメントを閉じる
createDocument | ドキュメントを作成する
createPage | ページを作成する
deleteDocument | ドキュメントファイルを削除する
deletePage | ページを削除する
DoCommand | コマンドを実行する
openDocument | ドキュメントを開く
saveDocument | ドキュメントを保存する
start | マネージ処理開始 (CommonLayerstart()()()をオーバーライド)
stop | マネージ処理終了 (CommonLayerstop()()()をオーバーライド)
takeoverDocument | 開いているドキュメントを管理下に追加する
takeoverPage | 既存のページを管理下に追加する

フィールド

名前 | 説明
ResponseFuncs | 処理終了時コールバック変数
VisioClosedFunc | Visio終了検出コールバック変数

参照

GraphWeaverMng クラス
Sakura.GW.AbstractLayer.Visio 名前空間


GraphWeaverMng コンストラクタ

[image] [image]

GraphWeaver For Visio ver.1.10
GraphWeaverMng コンストラクタ
GraphWeaverMng クラス 参照 フィードバックの送信

オーバーロードの一覧

名前 | 説明
GraphWeaverMng(IVisioDrawAccess) | コンストラクタ（使用推奨）
GraphWeaverMng(IVisioDrawAccess, Boolean) | コンストラクタ

参照

GraphWeaverMng クラス
GraphWeaverMng メンバ
Sakura.GW.AbstractLayer.Visio 名前空間


GraphWeaverMng コンストラクタ ()

[image]

GraphWeaver For Visio ver.1.10
GraphWeaverMng コンストラクタ ()
GraphWeaverMng クラス 使用例 参照 フィードバックの送信
コンストラクタ（使用推奨）

名前空間 Sakura.GW.AbstractLayer.Visio
アセンブリ： Sakura.GW.AbstractLayer.Visio (Sakura.GW.AbstractLayer.Visio.dll 内)
バージョン: 1.1.0.0 (1.1.0.0)

構文

C#
public GraphWeaverMng(
    IVisioDrawAccess drawClass
)
Visual Basic (宣言)
Public Sub New ( _
    drawClass As IVisioDrawAccess _
)
Visual C++
public:
GraphWeaverMng(
    IVisioDrawAccess^ drawClass
)

パラメータ

drawClass
型：IVisioDrawAccess
Visio描画処理クラス

解説

Visioへ描画を行うVisio描画処理クラスを引数としてインスタンスを生成します。

使用例

Visio描画処理クラスインスタンスを生成し、コンストラクタを呼び出す
CopyC#
VisioAddInLib_draw drawClass = new VisioAddInLib_draw();
GraphWeaverMng mng = new GraphWeaverMng(drawClass);

参照

GraphWeaverMng クラス
GraphWeaverMng オーバーロード
Sakura.GW.AbstractLayer.Visio 名前空間


GraphWeaverMng コンストラクタ (, Boolean)

[image]

GraphWeaver For Visio ver.1.10
GraphWeaverMng コンストラクタ (, Boolean)
GraphWeaverMng クラス 使用例 参照 フィードバックの送信
コンストラクタ

名前空間 Sakura.GW.AbstractLayer.Visio
アセンブリ： Sakura.GW.AbstractLayer.Visio (Sakura.GW.AbstractLayer.Visio.dll 内)
バージョン: 1.1.0.0 (1.1.0.0)

構文

C#
public GraphWeaverMng(
    IVisioDrawAccess drawClass,
    bool bLogging
)
Visual Basic (宣言)
Public Sub New ( _
    drawClass As IVisioDrawAccess, _
    bLogging As Boolean _
)
Visual C++
public:
GraphWeaverMng(
    IVisioDrawAccess^ drawClass,
    bool bLogging
)

パラメータ

drawClass
型：IVisioDrawAccess
Visio描画処理クラス
bLogging
型：System..::.Boolean
GraphWeaverロギングフラグ

解説

Visioへ描画を行うVisio描画処理クラスを引数としてインスタンスを生成します。
bLoggingにtrueを指定すると、ログファイルを作成し動作を記録します。
（重要！）ログファイルの管理は別途実装してください。

使用例

Visio描画処理クラスインスタンスを生成し、コンストラクタを呼び出す
CopyC#
VisioAddInLib_draw drawClass = new VisioAddInLib_draw();
GraphWeaverMng mng = new GraphWeaverMng(drawClass, true);

参照

GraphWeaverMng クラス
GraphWeaverMng オーバーロード
Sakura.GW.AbstractLayer.Visio 名前空間


GraphWeaverMng フィールド

[image] [image]

GraphWeaver For Visio ver.1.10
GraphWeaverMng フィールド
GraphWeaverMng クラス 参照 フィードバックの送信

GraphWeaverMng 型で公開されるメンバを以下の表に示します。

フィールド

名前 | 説明
ResponseFuncs | 処理終了時コールバック変数
VisioClosedFunc | Visio終了検出コールバック変数

参照

GraphWeaverMng クラス
Sakura.GW.AbstractLayer.Visio 名前空間


ResponseFuncs フィールド

[image]

GraphWeaver For Visio ver.1.10
GraphWeaverMng..::.ResponseFuncs フィールド
GraphWeaverMng クラス 使用例 参照 フィードバックの送信
処理終了時コールバック変数

名前空間 Sakura.GW.AbstractLayer.Visio
アセンブリ： Sakura.GW.AbstractLayer.Visio (Sakura.GW.AbstractLayer.Visio.dll 内)
バージョン: 1.1.0.0 (1.1.0.0)

構文

C#
public GraphWeaverMng..::.callbackResponse ResponseFuncs
Visual Basic (宣言)
Public ResponseFuncs As GraphWeaverMng..::.callbackResponse
Visual C++
public:
GraphWeaverMng..::.callbackResponse^ ResponseFuncs

解説

コマンド処理が終了した時に呼び出されるコールバック関数を登録します。

使用例

コールバック関数calledFuncを処理終了時コールバックとして登録
CopyC#
VisioAddInLib_draw drawClass = new VisioAddInLib_draw();
GraphWeaverMng mng = new GraphWeaverMng(drawClass);
mng.ResponseFuncs = new GraphWeaverMng.callbackResponse(calledFunc);

参照

GraphWeaverMng クラス
Sakura.GW.AbstractLayer.Visio 名前空間


VisioClosedFunc フィールド

[image]

GraphWeaver For Visio ver.1.10
GraphWeaverMng..::.VisioClosedFunc フィールド
GraphWeaverMng クラス 使用例 参照 フィードバックの送信
Visio終了検出コールバック変数

名前空間 Sakura.GW.AbstractLayer.Visio
アセンブリ： Sakura.GW.AbstractLayer.Visio (Sakura.GW.AbstractLayer.Visio.dll 内)
バージョン: 1.1.0.0 (1.1.0.0)

構文

C#
public GraphWeaverMng..::.callbackVisioClosed VisioClosedFunc
Visual Basic (宣言)
Public VisioClosedFunc As GraphWeaverMng..::.callbackVisioClosed
Visual C++
public:
GraphWeaverMng..::.callbackVisioClosed^ VisioClosedFunc

解説

直接または外部要因によってVisioが終了した時に呼び出されるコールバック関数を登録します。

使用例

コールバック関数calledVisioFuncをVisio終了検出コールバックとして登録
CopyC#
VisioAddInLib_draw drawClass = new VisioAddInLib_draw();
GraphWeaverMng mng = new GraphWeaverMng(drawClass);
mng.VisioClosedFunc = new GraphWeaverMng.callbackVisioClosed(calledVisioFunc);

参照

GraphWeaverMng クラス
Sakura.GW.AbstractLayer.Visio 名前空間


GraphWeaverMng メソッド

[image] [image]

GraphWeaver For Visio ver.1.10
GraphWeaverMng メソッド
GraphWeaverMng クラス 参照 フィードバックの送信

GraphWeaverMng 型で公開されるメンバを以下の表に示します。

メソッド

名前 | 説明
closeDocument | ドキュメントを閉じる
createDocument | ドキュメントを作成する
createPage | ページを作成する
deleteDocument | ドキュメントファイルを削除する
deletePage | ページを削除する
DoCommand | コマンドを実行する
openDocument | ドキュメントを開く
saveDocument | ドキュメントを保存する
start | マネージ処理開始 (CommonLayerstart()()()をオーバーライド)
stop | マネージ処理終了 (CommonLayerstop()()()をオーバーライド)
takeoverDocument | 開いているドキュメントを管理下に追加する
takeoverPage | 既存のページを管理下に追加する

参照

GraphWeaverMng クラス
Sakura.GW.AbstractLayer.Visio 名前空間


closeDocument メソッド

[image]

GraphWeaver For Visio ver.1.10
GraphWeaverMng..::.closeDocument メソッド
GraphWeaverMng クラス 使用例 参照 フィードバックの送信
ドキュメントを閉じる

名前空間 Sakura.GW.AbstractLayer.Visio
アセンブリ： Sakura.GW.AbstractLayer.Visio (Sakura.GW.AbstractLayer.Visio.dll 内)
バージョン: 1.1.0.0 (1.1.0.0)

構文

C#
public bool closeDocument(
    long index
)
Visual Basic (宣言)
Public Function closeDocument ( _
    index As Long _
) As Boolean
Visual C++
public:
bool closeDocument(
    long long index
)

パラメータ

index
型：System..::.Int64
識別用インデックス

戻り値

型：Boolean
成功時はtrue、失敗時はfalse。

解説

GraphWeaverMng管理下のドキュメントを閉じ、管理下から解放します。
indexには、保存するドキュメント識別値を指定します。

使用例

識別値docIndexのドキュメントを閉じます。
CopyC#
bool bRet = visioManager.closeDocument(docIndex);

参照

GraphWeaverMng クラス
Sakura.GW.AbstractLayer.Visio 名前空間


createDocument メソッド

[image]

GraphWeaver For Visio ver.1.10
GraphWeaverMng..::.createDocument メソッド
GraphWeaverMng クラス 参照 フィードバックの送信
ドキュメントを作成する

名前空間 Sakura.GW.AbstractLayer.Visio
アセンブリ： Sakura.GW.AbstractLayer.Visio (Sakura.GW.AbstractLayer.Visio.dll 内)
バージョン: 1.1.0.0 (1.1.0.0)

構文

C#
public bool createDocument(
    string templateDocPath,
    out long index
)
Visual Basic (宣言)
Public Function createDocument ( _
    templateDocPath As String, _
    <OutAttribute> ByRef index As Long _
) As Boolean
Visual C++
public:
bool createDocument(
    String^ templateDocPath,
    [OutAttribute] long long% index
)

パラメータ

templateDocPath
型：System..::.String
テンプレートドキュメント名
index
型： System..::.Int64 %
識別用インデックス

戻り値

型：Boolean
成功時はtrue、失敗時はfalse。

解説

新規ドキュメントを作成しGraphWeaverMngの管理下に追加します。
テンプレートとするファイルを指定する時は、templateDocPathに指定してください。
indexは、成功時ドキュメント識別値が、失敗時には-1が返ります。

参照

GraphWeaverMng クラス
Sakura.GW.AbstractLayer.Visio 名前空間


createPage メソッド

[image]

GraphWeaver For Visio ver.1.10
GraphWeaverMng..::.createPage メソッド
GraphWeaverMng クラス 使用例 参照 フィードバックの送信
ページを作成する

名前空間 Sakura.GW.AbstractLayer.Visio
アセンブリ： Sakura.GW.AbstractLayer.Visio (Sakura.GW.AbstractLayer.Visio.dll 内)
バージョン: 1.1.0.0 (1.1.0.0)

構文

C#
public bool createPage(
    long docIndex,
    ref string pageName
)
Visual Basic (宣言)
Public Function createPage ( _
    docIndex As Long, _
    ByRef pageName As String _
) As Boolean
Visual C++
public:
bool createPage(
    long long docIndex,
    String^% pageName
)

パラメータ

docIndex
型：System..::.Int64
識別用インデックス
pageName
型： System..::.String %
ページ名

戻り値

型：Boolean
成功時はtrue、失敗時はfalse。

解説

指定したドキュメントに新規ページを作成し、GraphWeaverMngの管理下に追加します。
docIndexには、追加するドキュメント識別値を指定します。
pageNameには、追加するページの名前を指定します。空文字の場合は任意の名前が割り当てられます。
対象ドキュメントに同じpageNameのページが存在する場合、必ず失敗します。

使用例

識別値docIndexのドキュメントにページ名"New Graph1"のページを新規作成する。
CopyC#
string pageName = "New Graph1";

bool bRet = visioManager.createPage(docIndex, ref pageName);

参照

GraphWeaverMng クラス
Sakura.GW.AbstractLayer.Visio 名前空間


deleteDocument メソッド

[image]

GraphWeaver For Visio ver.1.10
GraphWeaverMng..::.deleteDocument メソッド
GraphWeaverMng クラス 使用例 参照 フィードバックの送信
ドキュメントファイルを削除する

名前空間 Sakura.GW.AbstractLayer.Visio
アセンブリ： Sakura.GW.AbstractLayer.Visio (Sakura.GW.AbstractLayer.Visio.dll 内)
バージョン: 1.1.0.0 (1.1.0.0)

構文

C#
public bool deleteDocument(
    string fullPath
)
Visual Basic (宣言)
Public Function deleteDocument ( _
    fullPath As String _
) As Boolean
Visual C++
public:
bool deleteDocument(
    String^ fullPath
)

パラメータ

fullPath
型：System..::.String
ファイルフルパス

戻り値

型：Boolean
成功時はtrue、失敗時はfalse。

解説

指定したドキュメントファイルを削除します。
fullPathには、削除するドキュメントファイルパスを指定します。
GraphWeaverMngの管理下、または管理外のファイルを指定できます。
ファイルのアクセス権限等で成功不可能な時がありますので、注意してください。

使用例

ファイルパスfullPathのドキュメントファイルを削除します。
CopyC#
string fullPath = @"C:\doc.vsd";

bool bRet = visioManager.deleteDocument(fullPath);

参照

GraphWeaverMng クラス
Sakura.GW.AbstractLayer.Visio 名前空間


deletePage メソッド

[image]

GraphWeaver For Visio ver.1.10
GraphWeaverMng..::.deletePage メソッド
GraphWeaverMng クラス 使用例 参照 フィードバックの送信
ページを削除する

名前空間 Sakura.GW.AbstractLayer.Visio
アセンブリ： Sakura.GW.AbstractLayer.Visio (Sakura.GW.AbstractLayer.Visio.dll 内)
バージョン: 1.1.0.0 (1.1.0.0)

構文

C#
public bool deletePage(
    long docIndex,
    string pageName
)
Visual Basic (宣言)
Public Function deletePage ( _
    docIndex As Long, _
    pageName As String _
) As Boolean
Visual C++
public:
bool deletePage(
    long long docIndex,
    String^ pageName
)

パラメータ

docIndex
型：System..::.Int64
識別用インデックス
pageName
型：System..::.String
ページ名

戻り値

型：Boolean
成功時はtrue、失敗時はfalse。

解説

指定したドキュメントの既存ページを削除し、GraphWeaverMngの管理下から解放します。
docIndexには、追加するドキュメント識別値を指定します。
pageNameには、追加するページの名前を指定します。空文字は必ず失敗します。

使用例

識別値docIndexのドキュメント、ページ名"New Graph1"を削除し、GraphWeaverMngの管理下から解放する。
CopyC#
string pageName = "New Graph1";

bool bRet = visioManager.deletePage(docIndex, pageName);

参照

GraphWeaverMng クラス
Sakura.GW.AbstractLayer.Visio 名前空間


DoCommand メソッド

[image]

GraphWeaver For Visio ver.1.10
GraphWeaverMng..::.DoCommand メソッド
GraphWeaverMng クラス 参照 フィードバックの送信
コマンドを実行する

名前空間 Sakura.GW.AbstractLayer.Visio
アセンブリ： Sakura.GW.AbstractLayer.Visio (Sakura.GW.AbstractLayer.Visio.dll 内)
バージョン: 1.1.0.0 (1.1.0.0)

構文

C#
public bool DoCommand(
    long docIndex,
    GraphWeaverData mngInfo
)
Visual Basic (宣言)
Public Function DoCommand ( _
    docIndex As Long, _
    mngInfo As GraphWeaverData _
) As Boolean
Visual C++
public:
bool DoCommand(
    long long docIndex,
    GraphWeaverData^ mngInfo
)

パラメータ

docIndex
型：System..::.Int64
識別用インデックス
mngInfo
型：Sakura.GW.AbstractLayer..::.GraphWeaverData
GraphWeaver設定

戻り値

型：Boolean
実行開始成功時はtrue、失敗時はfalse。

解説

GraphWeaverDataクラスに設定されたコマンドを実行します。
コマンドの戻り値はGraphWeaverMng.ResponseFuncsに登録したコールバック関数で受け取ります。

参照

GraphWeaverMng クラス
Sakura.GW.AbstractLayer.Visio 名前空間
Sakura.GW.AbstractLayer..::.GraphWeaverData


openDocument メソッド

[image]

GraphWeaver For Visio ver.1.10
GraphWeaverMng..::.openDocument メソッド
GraphWeaverMng クラス 使用例 参照 フィードバックの送信
ドキュメントを開く

名前空間 Sakura.GW.AbstractLayer.Visio
アセンブリ： Sakura.GW.AbstractLayer.Visio (Sakura.GW.AbstractLayer.Visio.dll 内)
バージョン: 1.1.0.0 (1.1.0.0)

構文

C#
public bool openDocument(
    string fullPath,
    out string docName,
    out long index
)
Visual Basic (宣言)
Public Function openDocument ( _
    fullPath As String, _
    <OutAttribute> ByRef docName As String, _
    <OutAttribute> ByRef index As Long _
) As Boolean
Visual C++
public:
bool openDocument(
    String^ fullPath,
    [OutAttribute] String^% docName,
    [OutAttribute] long long% index
)

パラメータ

fullPath
型：System..::.String
ドキュメントパス
docName
型： System..::.String %
ドキュメント名取得
index
型： System..::.Int64 %
識別用インデックス(out)

戻り値

型：Boolean
成功時または既に開いているドキュメントの場合はtrue、失敗時はfalse。

解説

既存ドキュメントを開いてGraphWeaverMngの管理下に追加します。
２重に呼び出して、関数コール時に既に開いていた場合は同値のindexを返します。
fullPathは、ドライブ名からファイル名までの全パスを指定します。
docNameは、開かれたファイルのドキュメント名が返ります。
indexは、成功時ドキュメント識別値が、失敗時には-1が返ります。

使用例

Cドライブのdoc.vsdファイルを開く
CopyC#
string docFullPath = @"C:\doc.vsd"; // file path
string docName; // doc name
long docIndex;  // doc index(doc ID value)

bool bRet = visioManager.openDocument(docFullPath, out docName, out docIndex);

参照

GraphWeaverMng クラス
Sakura.GW.AbstractLayer.Visio 名前空間


saveDocument メソッド

[image]

GraphWeaver For Visio ver.1.10
GraphWeaverMng..::.saveDocument メソッド
GraphWeaverMng クラス 使用例 参照 フィードバックの送信
ドキュメントを保存する

名前空間 Sakura.GW.AbstractLayer.Visio
アセンブリ： Sakura.GW.AbstractLayer.Visio (Sakura.GW.AbstractLayer.Visio.dll 内)
バージョン: 1.1.0.0 (1.1.0.0)

構文

C#
public bool saveDocument(
    long index,
    string fullPath
)
Visual Basic (宣言)
Public Function saveDocument ( _
    index As Long, _
    fullPath As String _
) As Boolean
Visual C++
public:
bool saveDocument(
    long long index,
    String^ fullPath
)

パラメータ

index
型：System..::.Int64
識別用インデックス
fullPath
型：System..::.String
ファイルフルパス。空文字時は指定済みのフルパスを使用

戻り値

型：Boolean
成功時はtrue、失敗時はfalse。

解説

GraphWeaverMng管理下のドキュメントをファイルに保存します。
indexには、保存するドキュメント識別値を指定します。 fullPathは、ファイルのドライブ名からファイル名までの全パスを指定します。

使用例

識別値docIndexのドキュメントをファイル（"C:\doc.vsd"）として保存します。
CopyC#
string fullPath = @"C:\doc.vsd"; // doc path

bool bRet = visioManager.saveDocument(docIndex, fullPath);

参照

GraphWeaverMng クラス
Sakura.GW.AbstractLayer.Visio 名前空間


start メソッド

[image]

GraphWeaver For Visio ver.1.10
GraphWeaverMng..::.start メソッド
GraphWeaverMng クラス 参照 フィードバックの送信
マネージ処理開始

名前空間 Sakura.GW.AbstractLayer.Visio
アセンブリ： Sakura.GW.AbstractLayer.Visio (Sakura.GW.AbstractLayer.Visio.dll 内)
バージョン: 1.1.0.0 (1.1.0.0)

構文

C#
public override void start()
Visual Basic (宣言)
Public Overrides Sub start
Visual C++
public:
virtual void start() override

解説

管理マネージャを起動し、マネージ処理を開始します。

参照

GraphWeaverMng クラス
Sakura.GW.AbstractLayer.Visio 名前空間


stop メソッド

[image]

GraphWeaver For Visio ver.1.10
GraphWeaverMng..::.stop メソッド
GraphWeaverMng クラス 参照 フィードバックの送信
マネージ処理終了

名前空間 Sakura.GW.AbstractLayer.Visio
アセンブリ： Sakura.GW.AbstractLayer.Visio (Sakura.GW.AbstractLayer.Visio.dll 内)
バージョン: 1.1.0.0 (1.1.0.0)

構文

C#
public override void stop()
Visual Basic (宣言)
Public Overrides Sub stop
Visual C++
public:
virtual void stop() override

解説

管理マネージャを終了させ、マネージ処理を終了します。

参照

GraphWeaverMng クラス
Sakura.GW.AbstractLayer.Visio 名前空間


takeoverDocument メソッド

[image]

GraphWeaver For Visio ver.1.10
GraphWeaverMng..::.takeoverDocument メソッド
GraphWeaverMng クラス 使用例 参照 フィードバックの送信
開いているドキュメントを管理下に追加する

名前空間 Sakura.GW.AbstractLayer.Visio
アセンブリ： Sakura.GW.AbstractLayer.Visio (Sakura.GW.AbstractLayer.Visio.dll 内)
バージョン: 1.1.0.0 (1.1.0.0)

構文

C#
public bool takeoverDocument(
    Object docHandle,
    out string docName,
    out string fullPath,
    out long index
)
Visual Basic (宣言)
Public Function takeoverDocument ( _
    docHandle As Object, _
    <OutAttribute> ByRef docName As String, _
    <OutAttribute> ByRef fullPath As String, _
    <OutAttribute> ByRef index As Long _
) As Boolean
Visual C++
public:
bool takeoverDocument(
    Object^ docHandle,
    [OutAttribute] String^% docName,
    [OutAttribute] String^% fullPath,
    [OutAttribute] long long% index
)

パラメータ

docHandle
型：System..::.Object
ドキュメントハンドル
docName
型： System..::.String %
ドキュメント名
fullPath
型： System..::.String %
ドキュメントファイルフルパス。一度も保存していないドキュメントの場合は空文字が返る。
index
型： System..::.Int64 %
識別用インデックス

戻り値

型：Boolean
成功時はtrue、失敗時はfalse。

解説

既に開いているドキュメントをGraphWeaverMng管理下に追加します。
操作として、openDocumentでもcreateDocumentでもないドキュメントに対して実行します。
docHandleは、開かれたファイルのドキュメント名が返ります。 docNameは、開かれたファイルのドキュメント名が返ります。 fullPathは、ドライブ名からファイル名までの全パスを指定します。
indexは、成功時ドキュメント識別値が、失敗時には-1が返ります。

使用例

現在アクティブなドキュメントをGraphWeaverMng管理下に追加します。
CopyC#
string docName;  // doc name
string fullPath; // doc path
long docIndex;   // doc index(doc ID value)

bool bRet = visioManager.takeoverDocument(myApp.ActiveDocument, out docName, out fullPath, out docIndex);

参照

GraphWeaverMng クラス
Sakura.GW.AbstractLayer.Visio 名前空間


takeoverPage メソッド

[image]

GraphWeaver For Visio ver.1.10
GraphWeaverMng..::.takeoverPage メソッド
GraphWeaverMng クラス 使用例 参照 フィードバックの送信
既存のページを管理下に追加する

名前空間 Sakura.GW.AbstractLayer.Visio
アセンブリ： Sakura.GW.AbstractLayer.Visio (Sakura.GW.AbstractLayer.Visio.dll 内)
バージョン: 1.1.0.0 (1.1.0.0)

構文

C#
public bool takeoverPage(
    long docIndex,
    string pageName
)
Visual Basic (宣言)
Public Function takeoverPage ( _
    docIndex As Long, _
    pageName As String _
) As Boolean
Visual C++
public:
bool takeoverPage(
    long long docIndex,
    String^ pageName
)

パラメータ

docIndex
型：System..::.Int64
識別用インデックス
pageName
型：System..::.String
ページ名

戻り値

型：Boolean
成功時はtrue、失敗時はfalse。

解説

指定したドキュメントの既存ページをGraphWeaverMngの管理下に追加します。
docIndexには、追加するドキュメント識別値を指定します。
pageNameには、追加するページの名前を指定します。空文字は必ず失敗します。
対象ドキュメントに同じpageNameのページが存在する場合、必ず失敗します。

使用例

識別値docIndexのドキュメント、ページ名"New Graph1"をGraphWeaverMngの管理下に追加する。
CopyC#
string pageName = "New Graph1";

bool bRet = visioManager.takeoverPage(docIndex, pageName);

参照

GraphWeaverMng クラス
Sakura.GW.AbstractLayer.Visio 名前空間


GraphWeaverMng.callbackResponse デリゲート

[image]

GraphWeaver For Visio ver.1.10
GraphWeaverMng..::.callbackResponse デリゲート
GraphWeaverMng クラス 参照 フィードバックの送信
処理終了時コールバック関数型

名前空間 Sakura.GW.AbstractLayer.Visio
アセンブリ： Sakura.GW.AbstractLayer.Visio (Sakura.GW.AbstractLayer.Visio.dll 内)
バージョン: 1.1.0.0 (1.1.0.0)

構文

C#
public delegate void callbackResponse(
    ErrorID eErrorID
)
Visual Basic (宣言)
Public Delegate Sub callbackResponse ( _
    eErrorID As ErrorID _
)
Visual C++
public delegate void callbackResponse(
    ErrorID eErrorID
)

パラメータ

eErrorID
型：Sakura.GW.Lib..::.ErrorID
共通エラーID

参照

Sakura.GW.AbstractLayer.Visio 名前空間


GraphWeaverMng.callbackVisioClosed デリゲート

[image]

GraphWeaver For Visio ver.1.10
GraphWeaverMng..::.callbackVisioClosed デリゲート
GraphWeaverMng クラス 参照 フィードバックの送信
Visio終了検出コールバック関数型

名前空間 Sakura.GW.AbstractLayer.Visio
アセンブリ： Sakura.GW.AbstractLayer.Visio (Sakura.GW.AbstractLayer.Visio.dll 内)
バージョン: 1.1.0.0 (1.1.0.0)

構文

C#
public delegate void callbackVisioClosed()
Visual Basic (宣言)
Public Delegate Sub callbackVisioClosed
Visual C++
public delegate void callbackVisioClosed()

参照

Sakura.GW.AbstractLayer.Visio 名前空間


Sakura.GW.Lib 名前空間

[image]

GraphWeaver For Visio ver.1.10
Sakura.GW.Lib 名前空間
フィードバックの送信
GraphWeaver コモンライブラリ

クラス

クラス | 説明
ListCopy | Pointリストコピークラス
StringConv | 文字列数値変換クラス

構造体

構造体 | 説明
Point | ３次元(X,Y,Z)データ格納構造体

列挙体

列挙体 | 説明
ErrorID | 共通エラーID


ErrorID 列挙体

[image]

GraphWeaver For Visio ver.1.10
ErrorID 列挙体
参照 フィードバックの送信
共通エラーID

名前空間 Sakura.GW.Lib
アセンブリ： Sakura.GW.Lib (Sakura.GW.Lib.dll 内)
バージョン: 1.1.0.0 (1.1.0.0)

構文

C#
public enum ErrorID
Visual Basic (宣言)
Public Enumeration ErrorID
Visual C++
public enum class ErrorID

メンバ

メンバ名 | 説明
NoError | エラーなし
UnknownCommand | コマンド不明
NotSupportCommand | 未対応コマンド
UnknownDataType | データタイプ不明
NotSupportDataType | 未対応データタイプ
UnknownFileType | ファイルタイプ不明
NotSupportFileType | 未対応ファイルタイプ
OpenFileError | ファイルオープン失敗
ReadFileError | ファイルリード失敗
WriteFileError | ファイルライト失敗
CreateFileError | ファイル作成失敗
DeleteFileError | ファイル削除失敗
DataFormatError | データフォーマットエラー
DataLimitError | データリミットエラー
UnknownGraphType | グラフタイプ不明
NotSupportGraphType | 未対応グラフタイプ
GraphFormatError | グラフフォーマットエラー
NotSupportDrawError | 描画未対応
DrawFormatError | 描画形式エラー
DrawProcLimitError | 描画同時実行数エラー
DrawInternalError | 描画クラス内部エラー
ProcAbort | 処理中断
ProcLimitOver | 同時処理数オーバー
InternalError | 内部エラー

解説

処理終了時コールバック関数型でコールバック時に通知されるエラーIDとして使用されます。

ID | 説明
NoError | コマンドが正常終了しました。
UnknownCommand | 不明なコマンドIDが指定されたため異常終了しました。
NotSupportCommand | 実行したコマンドIDは未対応のため異常終了しました。
UnknownDataType | 指定されたデータタイプが不明のため異常終了しました。
NotSupportDataType | 指定されたデータタイプは未対応のため異常終了しました。
UnknownFileType | 指定されたファイルタイプが不明のため異常終了しました。
NotSupportFileType | 指定されたファイルタイプは未対応です。
OpenFileError | ファイルオープンに失敗し異常終了しました。
ReadFileError | ファイルリードに失敗し異常終了しました。
WriteFileError | ファイルライトに失敗し異常終了しましたた。
CreateFileError | ファイル作成に失敗し異常終了しました。
DeleteFileError | ファイル削除に失敗し異常終了しました。
DataFormatError | データフォーマットに異常があるため異常終了しました。
DataLimitError | データ数の上限を超えたため異常終了しました。
UnknownGraphType | 指定されたグラフタイプが不明のため異常終了しました。
NotSupportGraphType | 指定されたグラフタイプは未対応のため異常終了しました。
GraphFormatError | グラフ設定項目に異常があるため異常終了しました。
NotSupportDrawError | 描画出力は未対応のため使用できません。
DrawFormatError | 描画形式に異常があり異常終了しました。
DrawProcLimitError | 描画処理の同時実行数上限を超え異常終了しました。
DrawInternalError | 描画クラスの内部でエラーが発生し異常終了しました。
ProcAbort | 処理中断コマンドが正常終了しました。
ProcLimitOver | 同時コマンド実行数の上限を超え異常終了しました。
InternalError | ライブラリの内部エラーで異常終了しました。

参照

Sakura.GW.Lib 名前空間
処理終了時コールバック関数型


ListCopy クラス

[image]

GraphWeaver For Visio ver.1.10
ListCopy クラス
メンバ 参照 フィードバックの送信
Pointリストコピークラス

名前空間 Sakura.GW.Lib
アセンブリ： Sakura.GW.Lib (Sakura.GW.Lib.dll 内)
バージョン: 1.1.0.0 (1.1.0.0)

構文

C#
public static class ListCopy
Visual Basic (宣言)
Public NotInheritable Class ListCopy
Visual C++
public ref class ListCopy abstract sealed

解説

Point構造体のListコンテナをコピーするための補助関数です。

コピーおよびクローンの２関数があります。

継承階層

System..::.Object
Sakura.GW.Lib..::.ListCopy

参照

ListCopy メンバ
Sakura.GW.Lib 名前空間
Point構造体


ListCopy メンバ

[image] [image]

GraphWeaver For Visio ver.1.10
ListCopy メンバ
ListCopy クラス メソッド 参照 フィードバックの送信

ListCopy 型で公開されるメンバを以下の表に示します。

メソッド

名前 | 説明
Clone | Point型リストの複製作成
Copy | Pointリストコピー

参照

ListCopy クラス
Sakura.GW.Lib 名前空間


ListCopy メソッド

[image] [image]

GraphWeaver For Visio ver.1.10
ListCopy メソッド
ListCopy クラス 参照 フィードバックの送信

ListCopy 型で公開されるメンバを以下の表に示します。

メソッド

名前 | 説明
Clone | Point型リストの複製作成
Copy | Pointリストコピー

参照

ListCopy クラス
Sakura.GW.Lib 名前空間


Clone メソッド

[image]

GraphWeaver For Visio ver.1.10
ListCopy..::.Clone メソッド
ListCopy クラス 参照 フィードバックの送信
Point型リストの複製作成

名前空間 Sakura.GW.Lib
アセンブリ： Sakura.GW.Lib (Sakura.GW.Lib.dll 内)
バージョン: 1.1.0.0 (1.1.0.0)

構文

C#
public static List<Point> Clone(
    List<Point> src
)
Visual Basic (宣言)
Public Shared Function Clone ( _
    src As List(Of Point) _
) As List(Of Point)
Visual C++
public:
static List<Point>^ Clone(
    List<Point>^ src
)

パラメータ

src
型：System.Collections.Generic..::.List <(Of <( Point >)>)
コピー元

戻り値

コピー

解説

コピー元のリスト内容と同じリストを作成します。

（コピー元と先は異なるPoint群を参照することになります）

参照

ListCopy クラス
Sakura.GW.Lib 名前空間


Copy メソッド

[image]

GraphWeaver For Visio ver.1.10
ListCopy..::.Copy メソッド
ListCopy クラス 参照 フィードバックの送信
Pointリストコピー

名前空間 Sakura.GW.Lib
アセンブリ： Sakura.GW.Lib (Sakura.GW.Lib.dll 内)
バージョン: 1.1.0.0 (1.1.0.0)

構文

C#
public static void Copy(
    List<Point> src,
    ref List<Point> dst
)
Visual Basic (宣言)
Public Shared Sub Copy ( _
    src As List(Of Point), _
    ByRef dst As List(Of Point) _
)
Visual C++
public:
static void Copy(
    List<Point>^ src,
    List<Point>^% dst
)

パラメータ

src
型：System.Collections.Generic..::.List <(Of <( Point >)>)
コピー元
dst
型： System.Collections.Generic..::.List <(Of <( Point >)>) %
コピー先

解説

コピー先のリスト内容をコピー元と同じにします。

（リストが同一のPoint群を参照することになります）

参照

ListCopy クラス
Sakura.GW.Lib 名前空間


Point 構造体

[image]

GraphWeaver For Visio ver.1.10
Point 構造体
メンバ 参照 フィードバックの送信
３次元(X,Y,Z)データ格納構造体

名前空間 Sakura.GW.Lib
アセンブリ： Sakura.GW.Lib (Sakura.GW.Lib.dll 内)
バージョン: 1.1.0.0 (1.1.0.0)

構文

C#
public struct Point
Visual Basic (宣言)
Public Structure Point
Visual C++
public value class Point

解説

１次元から３次元までのデータを格納するための構造体です。
次元数に合わせ、X,Y,Zの順で格納してください。 GraphWeaverでは、数値データをこの構造体で扱います。

参照

Point メンバ
Sakura.GW.Lib 名前空間


Point メンバ

[image] [image]

GraphWeaver For Visio ver.1.10
Point メンバ
Point 構造体 コンストラクタ メソッド プロパティ 参照 フィードバックの送信

Point 型で公開されるメンバを以下の表に示します。

コンストラクタ

名前 | 説明
Point | オーバーロードされます。

メソッド

名前 | 説明
setPoint | Pointコピー設定
setX | X値設定
setXY | XY値設定
setXYZ | XYZ値設定

プロパティ

名前 | 説明
x | X値
y | Y値
z | Z値

参照

Point 構造体
Sakura.GW.Lib 名前空間


Point コンストラクタ

[image] [image]

GraphWeaver For Visio ver.1.10
Point コンストラクタ
Point 構造体 参照 フィードバックの送信

オーバーロードの一覧

名前 | 説明
Point(Point) | コンストラクタ（コピー）
Point(Double) | コンストラクタ（一次元値）
Point(Double, Double) | コンストラクタ（二次元値）
Point(Double, Double, Double) | コンストラクタ（三次元値）

参照

Point 構造体
Point メンバ
Sakura.GW.Lib 名前空間


Point コンストラクタ (Point)

[image]

GraphWeaver For Visio ver.1.10
Point コンストラクタ (Point)
Point 構造体 参照 フィードバックの送信
コンストラクタ（コピー）

名前空間 Sakura.GW.Lib
アセンブリ： Sakura.GW.Lib (Sakura.GW.Lib.dll 内)
バージョン: 1.1.0.0 (1.1.0.0)

構文

C#
public Point(
    Point orgPoint
)
Visual Basic (宣言)
Public Sub New ( _
    orgPoint As Point _
)
Visual C++
public:
Point(
    Point orgPoint
)

パラメータ

orgPoint
型：Sakura.GW.Lib..::.Point
コピー元Point

参照

Point 構造体
Point オーバーロード
Sakura.GW.Lib 名前空間


Point コンストラクタ (Double)

[image]

GraphWeaver For Visio ver.1.10
Point コンストラクタ (Double)
Point 構造体 参照 フィードバックの送信
コンストラクタ（一次元値）

名前空間 Sakura.GW.Lib
アセンブリ： Sakura.GW.Lib (Sakura.GW.Lib.dll 内)
バージョン: 1.1.0.0 (1.1.0.0)

構文

C#
public Point(
    double val1
)
Visual Basic (宣言)
Public Sub New ( _
    val1 As Double _
)
Visual C++
public:
Point(
    double val1
)

パラメータ

val1
型：System..::.Double
X値

参照

Point 構造体
Point オーバーロード
Sakura.GW.Lib 名前空間


Point コンストラクタ (Double, Double)

[image]

GraphWeaver For Visio ver.1.10
Point コンストラクタ (Double, Double)
Point 構造体 参照 フィードバックの送信
コンストラクタ（二次元値）

名前空間 Sakura.GW.Lib
アセンブリ： Sakura.GW.Lib (Sakura.GW.Lib.dll 内)
バージョン: 1.1.0.0 (1.1.0.0)

構文

C#
public Point(
    double val1,
    double val2
)
Visual Basic (宣言)
Public Sub New ( _
    val1 As Double, _
    val2 As Double _
)
Visual C++
public:
Point(
    double val1,
    double val2
)

パラメータ

val1
型：System..::.Double
X値
val2
型：System..::.Double
Y値

参照

Point 構造体
Point オーバーロード
Sakura.GW.Lib 名前空間


Point コンストラクタ (Double, Double, Double)

[image]

GraphWeaver For Visio ver.1.10
Point コンストラクタ (Double, Double, Double)
Point 構造体 参照 フィードバックの送信
コンストラクタ（三次元値）

名前空間 Sakura.GW.Lib
アセンブリ： Sakura.GW.Lib (Sakura.GW.Lib.dll 内)
バージョン: 1.1.0.0 (1.1.0.0)

構文

C#
public Point(
    double val1,
    double val2,
    double val3
)
Visual Basic (宣言)
Public Sub New ( _
    val1 As Double, _
    val2 As Double, _
    val3 As Double _
)
Visual C++
public:
Point(
    double val1,
    double val2,
    double val3
)

パラメータ

val1
型：System..::.Double
X値
val2
型：System..::.Double
Y値
val3
型：System..::.Double
Z値

参照

Point 構造体
Point オーバーロード
Sakura.GW.Lib 名前空間


Point メソッド

[image] [image]

GraphWeaver For Visio ver.1.10
Point メソッド
Point 構造体 参照 フィードバックの送信

Point 型で公開されるメンバを以下の表に示します。

メソッド

名前 | 説明
setPoint | Pointコピー設定
setX | X値設定
setXY | XY値設定
setXYZ | XYZ値設定

参照

Point 構造体
Sakura.GW.Lib 名前空間


setPoint メソッド

[image]

GraphWeaver For Visio ver.1.10
Point..::.setPoint メソッド
Point 構造体 参照 フィードバックの送信
Pointコピー設定

名前空間 Sakura.GW.Lib
アセンブリ： Sakura.GW.Lib (Sakura.GW.Lib.dll 内)
バージョン: 1.1.0.0 (1.1.0.0)

構文

C#
public void setPoint(
    Point orgPoint
)
Visual Basic (宣言)
Public Sub setPoint ( _
    orgPoint As Point _
)
Visual C++
public:
void setPoint(
    Point orgPoint
)

パラメータ

orgPoint
型：Sakura.GW.Lib..::.Point
コピー元

参照

Point 構造体
Sakura.GW.Lib 名前空間


setX メソッド

[image]

GraphWeaver For Visio ver.1.10
Point..::.setX メソッド
Point 構造体 参照 フィードバックの送信
X値設定

名前空間 Sakura.GW.Lib
アセンブリ： Sakura.GW.Lib (Sakura.GW.Lib.dll 内)
バージョン: 1.1.0.0 (1.1.0.0)

構文

C#
public void setX(
    double val
)
Visual Basic (宣言)
Public Sub setX ( _
    val As Double _
)
Visual C++
public:
void setX(
    double val
)

パラメータ

val
型：System..::.Double
X値

参照

Point 構造体
Sakura.GW.Lib 名前空間


setXY メソッド

[image]

GraphWeaver For Visio ver.1.10
Point..::.setXY メソッド
Point 構造体 参照 フィードバックの送信
XY値設定

名前空間 Sakura.GW.Lib
アセンブリ： Sakura.GW.Lib (Sakura.GW.Lib.dll 内)
バージョン: 1.1.0.0 (1.1.0.0)

構文

C#
public void setXY(
    double val1,
    double val2
)
Visual Basic (宣言)
Public Sub setXY ( _
    val1 As Double, _
    val2 As Double _
)
Visual C++
public:
void setXY(
    double val1,
    double val2
)

パラメータ

val1
型：System..::.Double
X値
val2
型：System..::.Double
Y値

参照

Point 構造体
Sakura.GW.Lib 名前空間


setXYZ メソッド

[image]

GraphWeaver For Visio ver.1.10
Point..::.setXYZ メソッド
Point 構造体 参照 フィードバックの送信
XYZ値設定

名前空間 Sakura.GW.Lib
アセンブリ： Sakura.GW.Lib (Sakura.GW.Lib.dll 内)
バージョン: 1.1.0.0 (1.1.0.0)

構文

C#
public void setXYZ(
    double val1,
    double val2,
    double val3
)
Visual Basic (宣言)
Public Sub setXYZ ( _
    val1 As Double, _
    val2 As Double, _
    val3 As Double _
)
Visual C++
public:
void setXYZ(
    double val1,
    double val2,
    double val3
)

パラメータ

val1
型：System..::.Double
X値
val2
型：System..::.Double
Y値
val3
型：System..::.Double
Z値

参照

Point 構造体
Sakura.GW.Lib 名前空間


Point プロパティ

[image] [image]

GraphWeaver For Visio ver.1.10
Point プロパティ
Point 構造体 参照 フィードバックの送信

Point 型で公開されるメンバを以下の表に示します。

プロパティ

名前 | 説明
x | X値
y | Y値
z | Z値

参照

Point 構造体
Sakura.GW.Lib 名前空間


x プロパティ

[image]

GraphWeaver For Visio ver.1.10
Point..::.x プロパティ
Point 構造体 参照 フィードバックの送信
X値

名前空間 Sakura.GW.Lib
アセンブリ： Sakura.GW.Lib (Sakura.GW.Lib.dll 内)
バージョン: 1.1.0.0 (1.1.0.0)

構文

C#
public double x { get; }
Visual Basic (宣言)
Public ReadOnly Property x As Double
Visual C++
public:
property double x {
    double get ();
}

参照

Point 構造体
Sakura.GW.Lib 名前空間


y プロパティ

[image]

GraphWeaver For Visio ver.1.10
Point..::.y プロパティ
Point 構造体 参照 フィードバックの送信
Y値

名前空間 Sakura.GW.Lib
アセンブリ： Sakura.GW.Lib (Sakura.GW.Lib.dll 内)
バージョン: 1.1.0.0 (1.1.0.0)

構文

C#
public double y { get; }
Visual Basic (宣言)
Public ReadOnly Property y As Double
Visual C++
public:
property double y {
    double get ();
}

参照

Point 構造体
Sakura.GW.Lib 名前空間


z プロパティ

[image]

GraphWeaver For Visio ver.1.10
Point..::.z プロパティ
Point 構造体 参照 フィードバックの送信
Z値

名前空間 Sakura.GW.Lib
アセンブリ： Sakura.GW.Lib (Sakura.GW.Lib.dll 内)
バージョン: 1.1.0.0 (1.1.0.0)

構文

C#
public double z { get; }
Visual Basic (宣言)
Public ReadOnly Property z As Double
Visual C++
public:
property double z {
    double get ();
}

参照

Point 構造体
Sakura.GW.Lib 名前空間


StringConv クラス

[image]

GraphWeaver For Visio ver.1.10
StringConv クラス
メンバ 参照 フィードバックの送信
文字列数値変換クラス

名前空間 Sakura.GW.Lib
アセンブリ： Sakura.GW.Lib (Sakura.GW.Lib.dll 内)
バージョン: 1.1.0.0 (1.1.0.0)

構文

C#
public static class StringConv
Visual Basic (宣言)
Public NotInheritable Class StringConv
Visual C++
public ref class StringConv abstract sealed

解説

文字列を数値に変換するための簡易実装です。

継承階層

System..::.Object
Sakura.GW.Lib..::.StringConv

参照

StringConv メンバ
Sakura.GW.Lib 名前空間


StringConv メンバ

[image] [image]

GraphWeaver For Visio ver.1.10
StringConv メンバ
StringConv クラス メソッド 参照 フィードバックの送信

StringConv 型で公開されるメンバを以下の表に示します。

メソッド

名前 | 説明
toDouble | 文字列からDouble型変換
toUShort | 文字列からushort型変換

参照

StringConv クラス
Sakura.GW.Lib 名前空間


StringConv メソッド

[image] [image]

GraphWeaver For Visio ver.1.10
StringConv メソッド
StringConv クラス 参照 フィードバックの送信

StringConv 型で公開されるメンバを以下の表に示します。

メソッド

名前 | 説明
toDouble | 文字列からDouble型変換
toUShort | 文字列からushort型変換

参照

StringConv クラス
Sakura.GW.Lib 名前空間


toDouble メソッド

[image]

GraphWeaver For Visio ver.1.10
StringConv..::.toDouble メソッド
StringConv クラス 参照 フィードバックの送信
文字列からDouble型変換

名前空間 Sakura.GW.Lib
アセンブリ： Sakura.GW.Lib (Sakura.GW.Lib.dll 内)
バージョン: 1.1.0.0 (1.1.0.0)

構文

C#
public static bool toDouble(
    string convString,
    out double value
)
Visual Basic (宣言)
Public Shared Function toDouble ( _
    convString As String, _
    <OutAttribute> ByRef value As Double _
) As Boolean
Visual C++
public:
static bool toDouble(
    String^ convString,
    [OutAttribute] double% value
)

パラメータ

convString
型：System..::.String
変換文字列
value
型： System..::.Double %
変換値

戻り値

成功：true 失敗：false

参照

StringConv クラス
Sakura.GW.Lib 名前空間


toUShort メソッド

[image]

GraphWeaver For Visio ver.1.10
StringConv..::.toUShort メソッド
StringConv クラス 参照 フィードバックの送信
文字列からushort型変換

名前空間 Sakura.GW.Lib
アセンブリ： Sakura.GW.Lib (Sakura.GW.Lib.dll 内)
バージョン: 1.1.0.0 (1.1.0.0)

構文

C#
public static bool toUShort(
    string convString,
    out ushort value
)
Visual Basic (宣言)
Public Shared Function toUShort ( _
    convString As String, _
    <OutAttribute> ByRef value As UShort _
) As Boolean
Visual C++
public:
static bool toUShort(
    String^ convString,
    [OutAttribute] unsigned short% value
)

パラメータ

convString
型：System..::.String
変換文字列
value
型： System..::.UInt16 %
変換値

戻り値

成功：true 失敗：false

参照

StringConv クラス
Sakura.GW.Lib 名前空間